Bug 641338

Summary: f14 qemu-kvm KDE guests boot very slowly
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: amit.shah, awilliam, berrange, dwmw2, ehabkost, gcosta, itamar, jaswinder, jforbes, jlaska, jreznik, jsmith.fedora, kevin, knoel, markmc, nospam, oliver.henshaw, ondrejj, poelstra, rdieter, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-15 08:07:29 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 633298    

Description Rex Dieter 2010-10-08 09:28:59 EDT
on a x86_64 f13 host, using virt-manager/qemu-kvm , trying to test out Fedora-14-Beta-i686-Live-KDE.iso or Fedora-14-Beta-x86_64-Live-KDE.iso , booting these seems to hang, but others (adamw and poelcat) report that it's just very very slow.

On this same box, testing prior live images, like those for f12-kde-live and f13-kde-live boot and function as expected.
Comment 1 John Poelstra 2010-10-08 09:36:21 EDT
I was doing Fedora 14 guests on Fedora 12 x86_64 bare metal that were working great until sometime after the Fedora 14 alpha.  Now I can't boot a live CD and get to the login window.

Should this bug be moved to Fedora 14?
Comment 2 John Poelstra 2010-10-08 09:51:40 EDT
Moving to version "14" and blocking final release.

Per release criteria: "The release must boot successfully as a virtual guest in a situation where the virtual host is running the previous stable Fedora release (using Fedora's current preferred virtualization technology)
Comment 3 Rex Dieter 2010-10-08 10:18:06 EDT
Re: comment 1 
I have to concur, this seems to have happened sometime after F14-alpha for me too (the -alpha isos booted a-ok for me).
Comment 4 John Poelstra 2010-10-08 12:19:26 EDT
Update: running the latest Fedora 12 packages on my system, I can no longer boot the Fedora 14 as a KVM guest.  It gets to the end of the boot process and appears to hang the guest.  After waiting 5 minutes at 100% CPU on the hypervisor I kill the guest.
Comment 5 John Poelstra 2010-10-08 12:26:58 EDT
(In reply to comment #4)
> Update: running the latest Fedora 12 packages on my system, I can no longer
> boot the Fedora 14 as a KVM guest.  It gets to the end of the boot process and
> appears to hang the guest.  After waiting 5 minutes at 100% CPU on the
> hypervisor I kill the guest.

Clarification--I can no longer boot the Fedora 14 ALPHA
Comment 6 Adam Williamson 2010-10-08 14:12:56 EDT
John, your case is not covered under the criteria: "the previous stable Fedora release" means *one* release prior, not any prior supported release, so we only cover F14-on-F13.

I can confirm this bug for the KDE image but not any other case. The Beta KDE image boots extremely slowly (well, the boot process is mostly fine, it's KDE initialization that takes forever) in qemu/kvm/virt-manager on an F14 host. KDE then performs equally sluggishly once it's finally done booting. The other three Beta images boot and perform just fine. I suspect this has something to do with KDE desktop rendering but I'm really not sure what.
Comment 7 Adam Williamson 2010-10-08 14:16:58 EDT
As far as blocker status goes, we agreed we need more information and will review next week. We will try and test this with the 'vesa' driver, with ajax's fix for the use of vesa in KVMs.
Comment 8 John Poelstra 2010-10-11 22:32:41 EDT
Update: I updated my machine to Fedora 13 and the Fedora 14 virt guest experience is much improved with the Gnome LiveCD.  I consider this NOTABUG now.

This is no longer a blocker bug from my perspective.
Comment 9 John Poelstra 2010-10-12 11:53:28 EDT
Re-reviewing bug comments below it would appear the remaining issue here is KDE specific.  Are KDE-only bugs considered final release blockers (I don't see anything in the release criteria)?  If not, we should remove blocker status for this bug.
Comment 10 Justin M. Forbes 2010-10-12 12:28:06 EDT
I have not been able to reproduce outside of the KDE disk Image I was given last week.  I will look for a newer image and see if I can reproduce there, but standard F14 images are okay.  One thought, is KDE forcing graphics capability that is pushing softgl since the hardware doesnt exist? If so, that is going to be insanely slow to virtualize.
Comment 11 Adam Williamson 2010-10-12 16:10:49 EDT
"Are KDE-only bugs considered final release blockers (I don't see
anything in the release criteria)?  If not, we should remove blocker status for
this bug."

By precedent, yes. For many releases there's been a KDE Blocker bug which has blocked F14Blocker and we haven't challenged this in the blocker review process.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2010-10-12 16:12:07 EDT
adjusting summary and moving it to the KDE blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Adam Williamson 2010-10-12 16:13:12 EDT
adding KDE folks to CC.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Kevin Kofler 2010-10-12 16:43:06 EDT
Compositing and the desktop effects which require it are disabled by default in Fedora, I don't think KDE is attempting to use it at all. (And FWIW, even in upstream's default setup, compositing is only enabled by default on known-good graphics chipsets.)
Comment 15 James Laska 2010-10-13 12:32:13 EDT
(In reply to comment #14)
> Compositing and the desktop effects which require it are disabled by default in
> Fedora, I don't think KDE is attempting to use it at all. (And FWIW, even in
> upstream's default setup, compositing is only enabled by default on known-good
> graphics chipsets.)

Thanks for the feedback.  If I understand correctly, since this is not a default configuration, we shouldn't consider this a KDE release blocker for F14-Final?

If so, is any additional confirmation needed from the KDE-SIG before we remove this from the list?
Comment 16 Kevin Kofler 2010-10-13 12:37:30 EDT
> If I understand correctly, since this is not a default configuration, we
> shouldn't consider this a KDE release blocker for F14-Final?

Unfortunately, you misunderstood.

The problem shows up with the default configuration. In comment #10, it was suggested as a possible cause that KDE might be requiring OpenGL and getting some slow software emulation, but this cannot be the issue in the default configuration. So we still haven't found the cause of the slowness.
Comment 17 James Laska 2010-10-13 12:45:22 EDT
(In reply to comment #16)
> > If I understand correctly, since this is not a default configuration, we
> > shouldn't consider this a KDE release blocker for F14-Final?
> 
> Unfortunately, you misunderstood.
> 
> The problem shows up with the default configuration. In comment #10, it was
> suggested as a possible cause that KDE might be requiring OpenGL and getting
> some slow software emulation, but this cannot be the issue in the default
> configuration. So we still haven't found the cause of the slowness.

Thanks for the correction.  We'll continue to monitor this issue for root cause.  I don't think I need to reiterate the urgency of resolving this issue.  If there are additional people or data needed to help move this forward, please don't hesitate to locate/request it.
Comment 18 Jared Smith 2010-10-14 13:33:02 EDT
It's not really clear to me what the status of this is... Is anyone actively trying to track down the issue?  Have we made a determination on whether or not this bug should block the release?  We're getting close to the wire here, and I want to make sure this bug gets the attention it deserves.
Comment 19 Adam Williamson 2010-10-14 14:40:51 EDT
"Have we made a determination on whether or not this bug should block the release?"

No. It's easy to tell this. If we did, it would either have the 'AcceptedBlocker' whiteboard field, or it would have the 'RejectedBlocker' whiteboard field and not be blocking a release-blocking bug any more. The fact that it is blocking a release-blocker bug but has no related whiteboard field means a final review of its blocker status has not yet been made.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Rex Dieter 2010-10-14 15:00:51 EDT
Tested a few fresh f14 images in kvm/qemu here on my f13 box, not much good to report, unfortunately.

f14.tc1.1 live kde i686 : see grub , immediately after booting, see white screen where normally boot process/plymouth appears  (seems to be some other unrelated plymouth-related problem?)

f14.rc1.1 live kde x86_64 : gets further than i686, then exhibits similar as this bug, last thing I see is:
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
though qemu isn't pegging the cpu on the host at this point.

kde-i386-20101013.16.iso : white screen, same as f14.tc1.1 live kde i686

kde-x86_64-20101013.16.iso : white screen, same as f14.tc1.1 live kde i686
Comment 21 Rex Dieter 2010-10-14 15:14:44 EDT
burned kde-i386-20101013.16.iso to cd, boots fine bare-metal. :(
Comment 22 Justin M. Forbes 2010-10-14 15:24:05 EDT
This is odd because I am seeing great performance with kde-x86_64-20101012.15.iso in kvm.  I am wondering, if you update to virt-preview packages for virt, does this fix things for you? Might be something in older qemu that doesnt exist in F14 hosts.
Comment 23 Oliver Henshaw 2010-10-14 20:25:18 EDT
I've just tested Fedora-14-x86_64-Live-KDE.iso (TC1.1) and kde-x86_64-20101013.16.iso (both times I gave the guests 512MB ram) and they boot and work, at least for a few minutes.

For reference the last nightly I tried before was kde-x86_64-20100928.17.iso which goes to a white screen while logging in but does boot to run level 3.


Note: It looks like kde-x86_64-20101013.16.iso is actually built with i686 packages for some reason (the logs show that the preceding nightly was normal in this regard).
Comment 24 Justin M. Forbes 2010-10-14 21:04:37 EDT
That may also be a difference, I give my guests considerably more memory than 512M, typically 2G, and never less than 1G.  Do we have memory contention issues? Still doing a bit more testing, but this doesn't seem to be an issue with F14 qemu at least, so I am not sure that I would consider it a blocker.  Seems odd to hold a release pending an update to a package in an older release unless it impacts upgrade.
Comment 25 Rex Dieter 2010-10-15 08:07:29 EDT
Using f13 + virt-preview repo + reboot later,

kde-i386-20101013.16.iso = works(*)
kde-x86_64-20101013.16.iso = works(*)
f14.tc1.1 live kde i686 = works(*)
f14.tc1.1 live kde x86_64 = works(*), though I can confirm this isn't really x86_64 per comment #23


so looks like things are testable with qemu-kvm again, and resolved to my own satisfaction.


(*) modulo the usual cirrus driver bug that makes the desktop look orange instead of blue, but that's not qemu's problem.
Comment 26 Adam Williamson 2010-10-18 17:02:56 EDT
yeah, I tested a TC1 KDE live image boot on a similarly up-to-date F14 host and it works okay, though it does seem to slow down over time (I don't give my VMs much memory, though, which could explain it).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Henry Kroll 2010-11-02 20:40:47 EDT
Desktop live Fedora-14-i686-Live-Desktop.iso is out today and taking over 10 minutes to boot on AMD Phenom(tm) 9600 Quad-Core Processor 4GB RAM, which ought to be fine.

Tried various options, including
qemu-kvm -hda fedo.qcow2 -cdrom Fed* -m 1024&
Comment 28 Kevin Kofler 2010-11-02 20:47:36 EDT
Uh, that's the GNOME image, the report is about the KDE one.
Comment 29 Kevin Kofler 2010-11-02 20:48:27 EDT
Oh wait, you're saying now the GNOME one is being slow… Maybe the same issue…
Comment 30 Adam Williamson 2010-11-02 21:14:03 EDT
I don't think so. I had this issue with some KDE live images but never with the GNOME desktop, and both final KDE and final GNOME boot fine for me. I think it's something different, Henry, please file a new report.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 31 Henry Kroll 2010-11-06 02:46:24 EDT
Works now, with the recent glib update. Carry on!