Bug 641496

Summary: iotop tracebacks and doesn't work.
Product: [Fedora] Fedora EPEL Reporter: Kevin Fenzi <kevin>
Component: iotopAssignee: Michal Hlavinka <mhlavink>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: el5CC: apiemont, mhlavink, wnefal+redhatbugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: iotop-0.4.1-2.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-03 17:58:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Kevin Fenzi 2010-10-08 21:50:30 UTC
[kevin@draco ~]$ iotop
Traceback (most recent call last):
  File "/usr/bin/iotop", line 16, in ?
    main()
  File "/usr/lib/python2.4/site-packages/iotop/ui.py", line 565, in main
    main_loop()
  File "/usr/lib/python2.4/site-packages/iotop/ui.py", line 555, in <lambda>
    main_loop = lambda: run_iotop(options)
  File "/usr/lib/python2.4/site-packages/iotop/ui.py", line 470, in run_iotop
    return curses.wrapper(run_iotop_window, options)
  File "/usr/lib/python2.4/curses/wrapper.py", line 44, in wrapper
    return func(stdscr, *args, **kwds)
  File "/usr/lib/python2.4/site-packages/iotop/ui.py", line 462, in run_iotop_window
    process_list = ProcessList(taskstats_connection, options)
  File "/usr/lib/python2.4/site-packages/iotop/data.py", line 369, in __init__
    self.update_process_counts()
  File "/usr/lib/python2.4/site-packages/iotop/data.py", line 425, in update_process_counts
    stats = self.taskstats_connection.get_single_task_stats(thread)
  File "/usr/lib/python2.4/site-packages/iotop/data.py", line 156, in get_single_task_stats
    reply = self.connection.recv()
  File "/usr/lib/python2.4/site-packages/iotop/netlink.py", line 229, in recv
    raise err
OSError: Netlink error: Invalid argument (22)
[kevin@draco ~]$ uname -r
2.6.18-194.17.1.el5

Comment 1 Michal Hlavinka 2010-10-11 09:47:32 UTC
(In reply to comment #0)
> [kevin@draco ~]$ uname -r
> 2.6.18-194.17.1.el5

and that's the problem, it should not allowed iotop installation because of unmet requires:

# rpm -qR iotop
...
kernel >= 2.6.18-199
...

I'll try to find out why this require does not work

Comment 2 Michal Hlavinka 2010-10-12 07:49:34 UTC
I've been told that "requires" on kernel release number does not work because of kernel packaging and it can be workarounded for arch packages only. So I've patched iotop to fix this, because even when required kernel would be installed there's no guarantee (on rpm level) that required kernel is also running.

now it reports error instead of traceback:
# iotop
iotop requires kernel-2.6.18-199.el5 or later, but kernel-2.6.18-194.11.3.el5 is running

Comment 3 Fedora Update System 2010-10-12 07:54:59 UTC
iotop-0.4.1-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/iotop-0.4.1-2.el5

Comment 4 Kevin Fenzi 2010-10-12 15:27:36 UTC
Out of curiosity, where does one obtain a 2.6.18-199 kernel? 
Is there going to be a public update of it sometime?

Currently this won't work on any centos machine at least.

Comment 5 Fedora Update System 2010-10-13 05:59:27 UTC
iotop-0.4.1-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iotop'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/iotop-0.4.1-2.el5

Comment 6 Michal Hlavinka 2010-10-13 13:57:57 UTC
(In reply to comment #4)
> Out of curiosity, where does one obtain a 2.6.18-199 kernel? 
> Is there going to be a public update of it sometime?
> 
> Currently this won't work on any centos machine at least.

Some testing kernels can be found here: http://people.redhat.com/jwilson/el5/

Usual statement: these are unofficial *testing* *unsupported* kernels

I've tested with old (produces new error message) and -225.el5 (works)

Comment 7 Fedora Update System 2011-02-03 17:58:21 UTC
iotop-0.4.1-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.