Bug 641911

Summary: freeze when inserting an old prism2.5 wifi pcmcia card
Product: [Fedora] Fedora Reporter: Fabrice Bellet <fabrice>
Component: kernelAssignee: Stanislaw Gruszka <sgruszka>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dougsland, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, sgruszka, tiagomatos
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-11 07:40:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
call trace none

Description Fabrice Bellet 2010-10-11 13:58:24 UTC
kernel oops is attached as a photo.

Comment 1 Fabrice Bellet 2010-10-11 14:00:30 UTC
Created attachment 452714 [details]
call trace

Comment 2 Stanislaw Gruszka 2011-01-07 10:38:41 UTC
I believe this is fixed not by:

commit 0f4da2d77e1bf424ac36424081afc22cbfc3ff2b
Author: John W. Linville <linville@tuxdriver.com>
Date:   Tue Jul 13 14:06:32 2010 -0400

    hostap_pci: set dev->base_addr during probe

commit d6a574ff6bfb842bdb98065da053881ff527be46
Author: Tim Gardner <tim.gardner@canonical.com>
Date:   Tue Jun 8 11:33:02 2010 -0600

    hostap: Protect against initialization interrupt


Fabrice, can you confirm?

Comment 3 Stanislaw Gruszka 2011-01-07 10:50:38 UTC
If problem still happens, please check this patch
https://bugzilla.redhat.com/attachment.cgi?id=472217

Comment 4 Stanislaw Gruszka 2011-01-07 14:42:19 UTC
Re comment 3. As reported in bug 643758, this patch not fully solve the problem from that bug, here is another one:
https://bugzilla.redhat.com/attachment.cgi?id=472242

Comment 5 Fabrice Bellet 2011-01-10 20:26:09 UTC
I confirm that 2.6.37-2.fc15.i686 + patch from comment #4 works for me.

thanks a lot for this fix!

Comment 6 Stanislaw Gruszka 2011-01-11 07:40:45 UTC
Great, I closing bug as duplicate.

*** This bug has been marked as a duplicate of bug 643758 ***