This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 641978

Summary: Unable to change LCD brightness on Dell Studio 1558 (Arrandale)
Product: [Fedora] Fedora Reporter: Jens Knutson <jensk.maps>
Component: xorg-x11-drv-intelAssignee: John Feeney <jfeeney>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 15CC: ajax, andersonkw2, collura, cott, cracksmoker, jfeeney, koptus, steevithak, todhunter, xgl-maint
Target Milestone: ---Keywords: Patch, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
See Also: https://launchpad.net/bugs/568611
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-07 15:36:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
xorg.0.log
none
dmesg
none
messages
none
acpidump dell xps l701x none

Description Jens Knutson 2010-10-11 13:13:07 EDT
I am unable to change the LCD brightness on my Dell Studio 1558 using any method I can find.  I've tried the brightness applet, the keyboard hotkeys, and I've tried directly echoing assorted values to  the brightness controls in /sys/devices/virtual/backlight/acpi_video0/ & /proc/acpi/video/GFX0/DD0X/.  No joy.

Graphics chip is the on-CPU Arrandale "Intel HD Graphics"

Here's my smolt:
http://www.smolts.org/client/show/pub_e95155fc-9a15-4da4-bbc2-4ca17c7dac50
Comment 1 Matěj Cepl 2010-10-23 19:01:24 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 aj 2010-10-30 18:26:30 EDT
Created attachment 456677 [details]
xorg.0.log
Comment 3 aj 2010-10-30 18:27:42 EDT
Created attachment 456678 [details]
dmesg
Comment 4 aj 2010-10-30 18:30:07 EDT
Created attachment 456679 [details]
messages
Comment 5 aj 2010-10-30 18:37:58 EDT
Same as above except Dell 14R (Intel core i3).  Attached requested info.  It seems there is a problem across the board with Intel core i3/5/7 laptops upstream.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/568611

http://lists.freedesktop.org/archives/intel-gfx/2010-September/008081.html

Mine:
http://www.smolts.org/client/show/pub_4deda161-6c83-407a-92cc-f5a8c9585846
Comment 6 Pawel 2010-11-13 10:20:31 EST
i have same problem on dell vostro 3500 with nvidia GF 310m. I tried change value in  /sys/devices/virtual/backlight/acpi_video0/brightness but that didn't help. Keys Fn+arrow up/down respond.
Comment 7 Steevithak 2011-01-29 23:45:47 EST
I'm running Fedora 14 on a Dell Studio 1558 with Intel i3 and ATI graphics. Changing screen brightness using the F4/F5 hotkeys works fine for me so maybe the problem is related to the intel graphics option? I can't find any sort of brightness screen applet but would be happy to test that method if someone posts instructions on how to test it. Also, if it would help any to have the DRM output from mine, I could try that too.
Comment 8 Matthew Garrett 2011-02-07 15:54:11 EST
Would it be possible for someone to install the pmtools package and run acpidump as root, then attach the output? I only need this for one of the Dells where brightness changing *doesn't* work.
Comment 9 todhunter 2011-02-15 23:26:06 EST
I have Dell XPS l701x and I can do acpidump but I dont know how to attache it to this thread. On my system I can increase brightness but I cant decrease
Comment 10 todhunter 2011-02-15 23:27:57 EST
Created attachment 479014 [details]
acpidump dell xps l701x
Comment 11 todhunter 2011-02-15 23:28:54 EST
ok I found how to attach acpidump
Comment 12 K. Anderson 2011-03-24 18:19:01 EDT
I can attach more information if needed. Currently FN and brightness controls are not working on my laptop either. I would like to see this fixed as it makes Fedora on my laptop unusable. :( I am on a Dell Studio 1558 Core i3 with integrated graphics.
Comment 13 Steevithak 2012-01-04 11:25:34 EST
I got an email on this bug today and it jogged my memory, I'd forgotten all about it because at some point in the past 9 months, it was resolved (at least for me). I am now able to change the LCD backlight brightness using the keyboard on my Dell Studio 1558. I'm still running Fedora 14. (sorry, no F15+, GNOME 3 just isn't useable for me). So unless someone else is still seeing the problem, you can probably close this one as fixed.
Comment 14 Cott Lang 2012-02-01 09:58:12 EST
This is *not* fixed in Fedora 16.  Odd Fedora 14 suddenly works.

Brightness controls do not work on my Dell Studio 1558 with Intel Graphics.

Strange that there was a kernel patch from Ubuntu that fixed this a year ago and it's not made it in yet?
Comment 15 Cott Lang 2012-02-01 10:22:07 EST
A bit of fiddling confirmed you can adjust it manually in /sys/class/backlight/intel_backlight/

Setting acpi_backlight=vendor fixes Gnome.

Hope this helps someone else - my battery is thankful! :)
Comment 16 Steevithak 2012-03-06 16:00:26 EST
I just updated to Fedora 16 and can confirm that this still works for me (lots of other stuff is broken in F16 and GNOME 3 still sucks but this feature does work).

There may be a hardware difference between my Dell Studio 1558 and Cott's. Mine has the ATI graphics card and the 1920x1080 LCD with LED backlighting. There were a lot of graphics card and screen combos available on this laptop, so I think what we're seeing is that the bug has been fixed for my screen or graphics card but not his.
Comment 17 Fedora End Of Life 2012-08-07 15:36:43 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping