This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 641991

Summary: Fedora 14 xorg qxl drv does not work with a RHEV-2.2 virtual machine
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: xorg-x11-serverAssignee: Adam Jackson <ajax>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: airlied, awilliam, hdegoede, jlaska, jrb, sandmann, xgl-maint
Target Milestone: ---Keywords: Patch, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: xorg-x11-server-1.9.0-15.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-15 08:43:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 635218    
Attachments:
Description Flags
PATCH: learn Xorg server to load the old qxl04 driver for revision 01 qxl devices
none
PATCH: learn Xorg server to nor load the qxl driver for revision 01 qxl devices none

Description Hans de Goede 2010-10-11 13:59:33 EDT
Hi,

The Summary says it all, this is because RHEV-2.2 (and 2.43 too) have the old spice-0.4 pci revision 1 qxl device and the new qxl driver will not work with those and has no fallback.

This bug is for tracking getting this fixed and for discussnig how to get it fixed.

Given the short amount of time before the F14 freeze I propose to package the old driver under a new name: xorg-x11-drv-qxl04 and teach the xorg-server to load the qxl04 driver for revision 1 devices as and the qxl driver for newer devices.

Then we can take our time to come up with a cleaner solution for F15 and later, or decide to stick with this solution.

Regards,

Hans
Comment 1 Hans de Goede 2010-10-11 14:13:52 EDT
Proposing this as a F14 blocker as it block F14 from installing into (certain) spice using virtual machines, which is an advertised F14 feature.
Comment 2 Hans de Goede 2010-10-11 14:39:00 EDT
Created attachment 452773 [details]
PATCH: learn Xorg server to load the old qxl04 driver for revision 01 qxl devices
Comment 3 Jonathan Blandford 2010-10-11 14:45:41 EDT
Ugh.  Don't like the two packages here.  I assume this is just for the short term and we're going to one package later.  Having multiple driver versions in multiple packages is going to be bad news in the long run.
Comment 4 Adam Jackson 2010-10-11 14:57:58 EDT
Do you actually have a qxl04 driver built anywhere?  Last I checked there was enough ABI skew between the last driver with revision 1 support and the X server that it wouldn't be trivial to rebuild.

Probably easier to just set the driver to 'vesa' instead of 'qxl04' there.
Comment 5 Hans de Goede 2010-10-11 15:39:29 EDT
(In reply to comment #4)
> Do you actually have a qxl04 driver built anywhere?

I've a local package ready to submit for review.

> Last I checked there was
> enough ABI skew between the last driver with revision 1 support and the X
> server that it wouldn't be trivial to rebuild.

There is one small patch needed which is already in the
xf86-video-qxl master

> Probably easier to just set the driver to 'vesa' instead of 'qxl04' there.

vesa does not work with the qxl device (I tried).
Comment 6 Hans de Goede 2010-10-11 17:16:24 EDT
Hi,

As discussed on irc the vesa driver does work, it not working was a bug in my local spice config.

So the best option for qxl revision 1 support in F-14 indeed is using the vesa driver. I'll attach an updated (and tested) patch. Changing component to server.

Thanks & Regards,

Hans
Comment 7 Hans de Goede 2010-10-11 17:17:20 EDT
Created attachment 452801 [details]
PATCH: learn Xorg server to nor load the qxl driver for revision 01 qxl devices
Comment 8 James Laska 2010-10-12 11:48:53 EDT
There are no release criteria pertaining to Fedora 14 and RHEV, can you help understand why this bug should be considered a blocker for the release?  And note ... we are about out of time.  Just because it is a feature doesn't qualify it as a release blocker.

Does this only impact RHEV, and when will RHEV be available?
Comment 9 Jonathan Blandford 2010-10-12 13:01:04 EDT
James, this means Fedora 14 won't work OOTB as a guest RHEV and RHEL-based hosts with spice turned on.  I'd like to get it in to the RC (as opposed to as an update) as it will affect anaconda.
Comment 10 Hans de Goede 2010-10-12 13:34:50 EDT
(In reply to comment #9)
> James, this means Fedora 14 won't work OOTB as a guest RHEV and RHEL-based
> hosts with spice turned on.  I'd like to get it in to the RC (as opposed to as
> an update) as it will affect anaconda.

Right, also note that there is a working and tested patch attached which already has been discussed with ajax. All that needs to happen is for someone to build a
new xorg-x11-server package with the patch.

Regards,

Hans
Comment 11 James Laska 2010-10-12 13:49:57 EDT
Thanks for the quick feedback!  I appreciate that this issue affects RHEV and RHEV-based hosts, but there are no Fedora 14 release criteria that indicate RHEV must work [1].  I'm inclined to mark this is a 'nice-to-have' (NTH) fix for Fedora 14.  Meaning, it won't block the release, but if a tested fix is available in time, it will be accepted.

THe posted patch indeed seems like a low-risk fix to take for NTH.

[1] https://fedoraproject.org/wiki/Fedora_14_Final_Release_Criteria
Comment 12 Adam Williamson 2010-10-12 13:51:12 EDT
I agree with James.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Fedora Update System 2010-10-13 11:34:56 EDT
xorg-x11-server-1.9.0-15.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.0-15.fc14
Comment 14 Fedora Update System 2010-10-13 17:20:05 EDT
xorg-x11-server-1.9.0-15.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.0-15.fc14
Comment 15 Fedora Update System 2010-10-15 08:43:17 EDT
xorg-x11-server-1.9.0-15.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.