Bug 643131

Summary: [abrt] radiotray-0.6.1-1.fc13: Notification.py:39:notify:GError: Unable to connect to server
Product: [Fedora] Fedora Reporter: Thomas Sievers <th.sievers>
Component: radiotrayAssignee: Jean-Francois Saucier <jsaucier>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: jsaucier, klemmerj, nathan
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: abrt_hash:02cecc75
Fixed In Version: radiotray-0.6.3-1.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-03 20:21:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace none

Description Thomas Sievers 2010-10-14 18:13:27 UTC
abrt version: 1.1.13
architecture: i686
cmdline: /usr/bin/python /usr/bin/radiotray
component: radiotray
executable: /usr/bin/radiotray
kernel: 2.6.34.7-56.fc13.i686.PAE
package: radiotray-0.6.1-1.fc13
reason: Notification.py:39:notify:GError: Unable to connect to server
release: Fedora release 13 (Goddard)
time: 1287079931
uid: 500

backtrace
-----
Notification.py:39:notify:GError: Unable to connect to server

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/radiotray/AudioPlayerGStreamer.py", line 114, in on_message
    self.mediator.notifyPlaying()
  File "/usr/lib/python2.6/site-packages/radiotray/StateMediator.py", line 104, in notifyPlaying
    self.notification.notify(C_("Notifies which radio is currently playing.", "Radio Tray Playing"), self.currentRadio)
  File "/usr/lib/python2.6/site-packages/radiotray/Notification.py", line 39, in notify
    self.notif.show()
GError: Unable to connect to server

Local variables in innermost frame:
message: '80s Sky.FM'
pixbuf: <gtk.gdk.Pixbuf object at 0xa221d4c (GdkPixbuf at 0xa299288)>
self: <radiotray.Notification.Notification instance at 0xa22370c>
title: 'Radio Tray Playing'

How to reproduce
-----
1. started radiotray after yum upgrade
2.
3.

Comment 1 Thomas Sievers 2010-10-14 18:13:29 UTC
Created attachment 453524 [details]
File: backtrace

Comment 2 Jean-Francois Saucier 2010-10-18 11:50:14 UTC
Hi,

Thanks for reporting this bug. Does radiotray do this every time on every radio you try to play?


Thank you!

Comment 3 Thomas Sievers 2010-10-18 17:18:25 UTC
yes

eachtime

radiotray is running fine but eachtime at sarting a new bug is automatic reported

Comment 4 Jean-Francois Saucier 2010-10-28 14:19:01 UTC
Ok, just to be sure I understand that one correctly :

- Radiotray is not running

- You start radiotray

- You choose a new radio to listen

- This error message popup but radiotray play fine


Is it correct? If yes, do you run GNOME, KDE, XFCE, etc?

Comment 5 Thomas Sievers 2010-10-28 16:21:36 UTC
It is correct!

I run Gnome or XFCE, both installed

Comment 6 Jean-Francois Saucier 2010-11-02 12:18:31 UTC
Thank you for the feedback.

My understanding is that the bug is caused by radiotray not being able to connect to the notification server.

Do you have a notification tray on your desktop?


Thanks!

Comment 7 Thomas Sievers 2010-11-03 03:57:51 UTC
yes i have, also from radiotray

Comment 8 Joe Klemmer 2010-11-09 00:15:45 UTC
Package: radiotray-0.6.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Started app for the first time
2. Selected a station (181.FM Classic Hits)
3. Stream started playing just as the notification of a crash happened


Comment
-----
This seems to be a crash that hasn't effedted the app.  I was able to switch to other stations and it kept playing.

Comment 9 Nathan Thomas 2010-12-02 20:01:52 UTC
Package: radiotray-0.6.1-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start radiotray.
2. Start playing a radio station.
3. Playback starts successfully and a correct notification is displayed, but ABRT complains of a crash.


Comment
-----
I am using F14 Xfce Spin x86_64 with xfce4-notifyd v.0.1.0-3.fc12 as my notification system, perhaps radiotray is expecting notification-daemon?

Comment 10 Fedora Update System 2011-01-24 17:26:17 UTC
radiotray-0.6.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/radiotray-0.6.3-1.fc14

Comment 11 Fedora Update System 2011-01-24 17:37:53 UTC
radiotray-0.6.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/radiotray-0.6.3-1.fc13

Comment 12 Nathan Thomas 2011-01-24 22:24:29 UTC
Package: radiotray-0.6.1-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Launch radiotray
2. Select a station
3. Radio starts playing fine, but for some reason ABRT reports a bug


Comment
-----
I'm using F14 Xfce Spin.

Comment 13 Nathan Thomas 2011-01-24 22:42:31 UTC
Whoops, forgot that I'd already submitted a bug report for this!

The radiotray 0.6.3 build from koji fixes this issue for me.

Comment 14 Fedora Update System 2011-01-25 20:56:37 UTC
radiotray-0.6.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update radiotray'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/radiotray-0.6.3-1.fc14

Comment 15 Fedora Update System 2011-02-03 20:20:49 UTC
radiotray-0.6.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-02-03 20:21:44 UTC
radiotray-0.6.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.