Bug 643287

Summary: Publican does not replace some <phrase>s in translated documents
Product: [Community] Publican Reporter: Jeff Fearn <jfearn>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 1.6CC: jfearn, khashida, mmcallis, publican-list, r.landmann
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=642497
Whiteboard:
Fixed In Version: publican-2.3-0.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 642497 Environment:
Last Closed: 2010-10-27 18:48:21 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Comment 1 Jeff Fearn 2010-10-15 03:33:19 EDT
Description of problem: 
Even when all the po.files have been translated properly, html and pdf show the 
English rendering at section 27.3. The English lines apparently are displayed
in all the supported languages.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 6 Installation Guide.


How reproducible:
Every time when you open the compiled document. 

Steps to Reproduce:
1.Compile html or pdf for the translated po.files of Installation Guide.
2.Go to section 27.3.
3.This section has three English lines which introduce the new online
resources.

Actual results:
English lines:
27.3. オンラインのリソース

For z/VM publications, refer to http://www.ibm.com/vm/library/ .

For System z I/O connectivity information, refer to
http://www.ibm.com/systems/z/connectivity/ .

For System z cryptographic coprocessor information, refer to
http://www.ibm.com/security/cryptocards/ .

Expected results:
These lines should be rendered properly with translated languages for all
supported languages
Comment 2 Jeff Fearn 2010-10-15 03:36:12 EDT
Because there was no translatable tag in the XML structure the text was completely excluded from the translation process.

Added phrase to list of block tags to translate.

POT and PO files will need to be regenerated to get this content in to the PO files.

Fixed in build: 2.2-0%{?dist}.t29
Comment 3 Ruediger Landmann 2010-10-21 02:12:56 EDT
Verified in build 2.2-0.fc13.t29 by updating POT files for Red Hat Enterprise Linux 6 Installation Guide.

POT file entries for <phrase>s inside <biblioentry>s are now generated as expected.
Comment 4 Kiyoto Hashida 2010-10-25 02:48:42 EDT
Has this been fixed yet ? We have to re-brew it and publish it when it is fixed.
Comment 5 Fedora Update System 2010-10-25 23:44:59 EDT
publican-2.3-0.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/publican-2.3-0.fc13
Comment 6 Fedora Update System 2010-10-27 18:47:40 EDT
publican-2.3-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.