Bug 644940

Summary: can't login after clean install
Product: [Fedora] Fedora Reporter: Martin Krizek <mkrizek>
Component: xfwm4Assignee: Kevin Fenzi <kevin>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: awilliam, dcantrell, kevin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: spin-kickstarts-0.14.4-3.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-20 19:49:38 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 635218    

Description Martin Krizek 2010-10-20 12:17:46 EDT
Description of problem:
When installing a system with all default choices except unchecking GNOME and choosing XFCE (XFCE is the only wm installed), after booting into a new system GDM shows up. When entering name and password screen blinks and gets back to GDM login.

Version-Release number of selected component (if applicable):
xfwm4-4.6.2-2.fc14.1

How reproducible:
Always.

Steps to Reproduce:
1. Clean install.
2. Uncheck GNOME.
3. Choose XFCE
  
Actual results:
Can't login into XFCE. GDM asks to login again.

Expected results:
Successful login to XFCE.

Additional info:
Fedora 14 Final TC1. Tested in KVM.
Comment 1 Kevin Fenzi 2010-10-20 12:20:18 EDT
How did you install? From what media exactly?
Comment 2 Martin Krizek 2010-10-20 12:27:58 EDT
Fedora-14-x86_64-DVD.iso
Comment 3 Kevin Fenzi 2010-10-20 12:33:45 EDT
Try: 

control-alt-f2
login as root
yum groupinstall xfce-desktop

Does it install a bunch of things? 
Does it work after that?
Comment 4 Martin Krizek 2010-10-20 12:50:39 EDT
It installed 36 packages. It does work after that.
Comment 5 Adam Williamson 2010-10-20 13:06:24 EDT
Jesse, Kevin and I have figured this one out: it's down to the change in firstboot to allow it to use window managers other than metacity. firstboot was set to require 'firstboot(windowmanager)' and metacity, kwin and xfwm4 all provide this. For TC1 purposes, openbox also did.

I think we established before that when there's a provide/requires setup like that, all possible providers are pulled in to DVD composes by default; so xfwm4 and openbox were pulled into the TC1 compose, causing the XFCE and LXDE package groups to show up in the installer choices.

If we can explicitly keep xfwm4 off the DVD compose, that should solve the problem. Since we discovered that openbox doesn't actually work for firstboot and pushed a package to stop openbox providing firstboot(windowmanager) - that's https://admin.fedoraproject.org/updates/openbox-3.4.11.2-5.fc14 - we shouldn't have to worry about the openbox/LXDE angle for RC1.

Tagging as NTH for now.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Fedora Update System 2010-10-20 19:24:48 EDT
spin-kickstarts-0.14.4-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/spin-kickstarts-0.14.4-3.fc14
Comment 7 Fedora Update System 2010-10-20 19:49:33 EDT
spin-kickstarts-0.14.4-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.