Bug 646807

Summary: nss-tools-3.12.7-6.fc13.x86_64 installation tries to install i686 dependencies on x86_64 system
Product: [Fedora] Fedora Reporter: Jean Gobin <jf>
Component: nssAssignee: Elio Maldonado Batiz <emaldona>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: emaldona, kdudka, kengert
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-28 13:32:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jean Gobin 2010-10-26 10:50:37 UTC
Description of problem:

When trying to install cman, an issue arises during the install of nss-tools. Although everything seems to go fine, that package tries to install i686 dependencies on a x86_64, which fails as the corresponding x86_64 are already installed.

Version-Release number of selected component (if applicable):

nss-tools-3.12.7-6.fc13.x86_64
Fedora 13/x86_64
Linux linux-node2 2.6.34.7-61.fc13.x86_64 #1 SMP Tue Oct 19 04:06:30 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Easily.

Steps to Reproduce:


yum install nss-tools-3.12.7-6.fc13.x86_64
  
Actual results:

[root@linux-node2 ~]# yum install nss-tools-3.12.7-6.fc13.x86_64
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package nss-tools.x86_64 0:3.12.7-6.fc13 set to be installed
--> Processing Dependency: nss = 3.12.7-6.fc13 for package: nss-tools-3.12.7-6.fc13.x86_64
--> Running transaction check
---> Package nss.i686 0:3.12.7-6.fc13 set to be installed
--> Processing Dependency: nss-softokn(x86-32) >= 3.12.7 for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libplds4.so for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.12.3) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libz.so.1 for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libnssutil3.so for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libc.so.6 for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.12.5) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libdl.so.2 for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libnspr4.so for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libplc4.so for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libpthread.so.0 for package: nss-3.12.7-6.fc13.i686
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.12) for package: nss-3.12.7-6.fc13.i686
--> Running transaction check
---> Package glibc.i686 0:2.12.1-3 set to be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.12.1-3.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12.1-3.i686
---> Package nspr.i686 0:4.8.6-1.fc13 set to be installed
---> Package nss-softokn.i686 0:3.12.7-6.fc13 set to be installed
--> Processing Dependency: libsqlite3.so.0 for package: nss-softokn-3.12.7-6.fc13.i686
---> Package nss-util.i686 0:3.12.7-2.fc13 set to be installed
---> Package zlib.i686 0:1.2.3-23.fc12 set to be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.12.7-6.fc13 set to be installed
---> Package sqlite.i686 0:3.6.22-1.fc13 set to be installed
--> Processing Dependency: libreadline.so.6 for package: sqlite-3.6.22-1.fc13.i686
--> Running transaction check
---> Package readline.i686 0:6.1-2.fc13 set to be installed
--> Processing Dependency: libtinfo.so.5 for package: readline-6.1-2.fc13.i686
--> Running transaction check
---> Package ncurses-libs.i686 0:5.7-7.20100130.fc13 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================================================
 Package                                                Arch                                       Version                                                    Repository                                   Size
================================================================================================================================================================================================================
Installing:
 nss-tools                                              x86_64                                     3.12.7-6.fc13                                              updates                                     744 k
Installing for dependencies:
 glibc                                                  i686                                       2.12.1-3                                                   updates                                     4.3 M
 ncurses-libs                                           i686                                       5.7-7.20100130.fc13                                        fedora                                      255 k
 nspr                                                   i686                                       4.8.6-1.fc13                                               updates                                     112 k
 nss                                                    i686                                       3.12.7-6.fc13                                              updates                                     752 k
 nss-softokn                                            i686                                       3.12.7-6.fc13                                              updates                                     171 k
 nss-softokn-freebl                                     i686                                       3.12.7-6.fc13                                              updates                                     113 k
 nss-util                                               i686                                       3.12.7-2.fc13                                              updates                                      45 k
 readline                                               i686                                       6.1-2.fc13                                                 fedora                                      181 k
 sqlite                                                 i686                                       3.6.22-1.fc13                                              fedora                                      309 k
 zlib                                                   i686                                       1.2.3-23.fc12                                              fedora                                       69 k

Transaction Summary
================================================================================================================================================================================================================
Install      11 Package(s)

Total size: 6.9 M
Installed size: 21 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  package nss-util-3.12.8-1.fc13.x86_64 (which is newer than nss-util-3.12.7-2.fc13.i686) is already installed
  package nss-3.12.8-2.fc13.x86_64 (which is newer than nss-3.12.7-6.fc13.i686) is already installed
  package nss-softokn-3.12.8-1.fc13.x86_64 (which is newer than nss-softokn-3.12.7-6.fc13.i686) is already installed
  package nss-softokn-freebl-3.12.8-1.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.7-6.fc13.i686) is already installed

Error Summary
-------------



Expected results:


Additional info:


The system has no i686 packages installed: 

[root@linux-node2 ~]# rpm -qa | grep i686 | wc -l
0
[root@linux-node2 ~]# rpm -qa | grep x86_64 | wc -l
245


When doing a yum deplist of the ns-tools package, a few i686 dependencies are displayed:

  dependency: nss = 3.12.7-6.fc13
   provider: nss.x86_64 3.12.7-6.fc13
   provider: nss.i686 3.12.7-6.fc13


  dependency: zlib
   provider: zlib.i686 1.2.3-23.fc12
   provider: zlib.x86_64 1.2.3-23.fc12

  dependency: rtld(GNU_HASH)
   provider: glibc.x86_64 2.12-1
   provider: glibc.i686 2.12-1
   provider: glibc.x86_64 2.12.1-3
   provider: glibc.i686 2.12.1-3


All the other dependencies correctly mention the x86_64 only. 

As mentioned in the yum install output, these are already installed in their x86_64 incarnation:

[root@linux-node2 ~]# rpm -qa | egrep '(glibc|ncurses-libs|nspr|nss|readline|sqlite|zlib)' 
glibc-common-2.12.1-3.x86_64
readline-6.1-2.fc13.x86_64
nss-util-3.12.8-1.fc13.x86_64
nss-softokn-3.12.8-1.fc13.x86_64
nss-3.12.8-2.fc13.x86_64
openssh-clients-5.4p1-3.fc13.x86_64
nss-softokn-freebl-3.12.8-1.fc13.x86_64
glibc-2.12.1-3.x86_64
ncurses-libs-5.7-7.20100130.fc13.x86_64
zlib-1.2.3-23.fc12.x86_64
nspr-4.8.6-1.fc13.x86_64
sqlite-3.6.22-1.fc13.x86_64
nss-sysinit-3.12.8-2.fc13.x86_64
openssl-1.0.0a-1.fc13.x86_64
openssh-5.4p1-3.fc13.x86_64
openssh-server-5.4p1-3.fc13.x86_64

It seems that yum install nss-tools requires both version to be present, which fails because the x86_64 is already installed and won't let the i686 install.

Comment 1 Jean Gobin 2010-10-28 13:32:40 UTC
It seems this was corrected, as of today: 

[root@linux-node2 ~]# yum install nss-tools
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package nss-tools.x86_64 0:3.12.8-2.fc13 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================================
 Package                    Arch                    Version                          Repository                Size
====================================================================================================================
Installing:
 nss-tools                  x86_64                  3.12.8-2.fc13                    updates                  749 k

Transaction Summary
====================================================================================================================
Install       1 Package(s)

Total download size: 749 k
Installed size: 3.1 M



Thanks!