Bug 648072

Summary: inhibit and brightness applets are missing
Product: [Fedora] Fedora Reporter: Julian Sikorski <belegdol>
Component: gnome-power-managerAssignee: Richard Hughes <rhughes>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: andreskru, cdadhemar, collura, dcleal, imc, jim, kparal, marek78uk, noel, ralph.clark, rhughes, theo148, turmlos
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-15 08:05:20 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Simple command-line work-a-like for the Inhibit Applet none

Description Julian Sikorski 2010-10-30 15:36:24 EDT
Description of problem:
The topic says it all. I was using the inhibit applet while mock building and to work around the totem bug (Gnome #618385). It seems the applets were disabled with 2.31.3-1, but were never added back after reverting to gtk2.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.32.0-3.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add an inhibit applet in Fedora 13
2. Upgrade to Fedora 14
  
Actual results:
Applet is gone

Expected results:
Applet is still available
Comment 1 andreskru 2010-11-15 12:28:48 EST
Same here.
Comment 2 markm 2010-11-16 18:28:03 EST
*** Bug 648109 has been marked as a duplicate of this bug. ***
Comment 3 markm 2010-11-16 18:30:21 EST
same here, very useful inhibit applet is gone :(
Comment 4 Theodore Lee 2010-12-05 02:30:19 EST
Recompiling the package without --disable-applets passed to configure (and uncommenting the relevant %files lines) seems to be working fine for me. Is there any chance the applets will be returning within the Fedora 14 time frame?
Comment 5 Noel J. Bergman 2011-01-04 09:36:31 EST
Created attachment 471677 [details]
Simple command-line work-a-like for the Inhibit Applet
Comment 6 Noel J. Bergman 2011-01-10 23:56:21 EST
http://www.devtech.com/inhibitapplet is a drop-in replacement for the missing inhibit applet, which should resolve the issue for folks.

It works as an App Indicator when that support is present (e.g., Ubuntu) or as a GNOME Panel Applet otherwise (e.g., Fedora), and provides independent control over all of the inhibit settings.

To make it easy to install as an applet, it checks for its own server file, and will attempt to write it if missing.  Once that's done, you add it to the panel in the normal manner.  And, being written in Python, it is easy to customize.
Comment 7 markm 2011-01-11 18:22:03 EST
(In reply to comment #6)
> http://www.devtech.com/inhibitapplet is a drop-in replacement for the missing
> inhibit applet, which should resolve the issue for folks.
> 
> It works as an App Indicator when that support is present (e.g., Ubuntu) or as
> a GNOME Panel Applet otherwise (e.g., Fedora), and provides independent control
> over all of the inhibit settings.
> 
> To make it easy to install as an applet, it checks for its own server file, and
> will attempt to write it if missing.  Once that's done, you add it to the panel
> in the normal manner.  And, being written in Python, it is easy to customize.

well done Noel!

but honestly, it would be great, if developers could just change the flag in the spec file and recompile power manager... for me it was really useful to have that applet and just click it whenever I wanted to re-calibrate my monitor or watch some flash videos full screen... very useful - don't understand why such a simple task is being ignored for months...
Comment 8 Kamil Páral 2011-01-12 09:17:13 EST
I talked to hughsie (package maintainer) on #fedora-devel. Current status:

1. Brightness applet is completely broken.
2. Inhibit applet probably still works.
3. Both applets are removed from Gnome master (Gnome 3.0).
4. Reverting spec change means adding one broken applet.
5. Quote: "hughsie: and i don't really want to bring them back, just to remove them again in the next fedora release"

Because of that, this seems to be a WONTFIX. I don't know when he finds time to take care of this report, therefore I have put at least this comment in here, so you folks know.
Comment 9 Ian Collier 2011-01-12 10:52:20 EST
Brightness applet is only slightly broken, and is currently the only way of controlling the brightness on my laptop (aside from gnome-power-preferences which is a sledgehammer to crack a nut) because if I adjust it with the hotkeys then g-p-m resets the brightness to what it thinks it should be within a couple of minutes.
Comment 10 markm 2011-01-12 17:17:29 EST
(In reply to comment #8)
> I talked to hughsie (package maintainer) on #fedora-devel. Current status:
> 
> 1. Brightness applet is completely broken.
> 2. Inhibit applet probably still works.
> 3. Both applets are removed from Gnome master (Gnome 3.0).
> 4. Reverting spec change means adding one broken applet.
> 5. Quote: "hughsie: and i don't really want to bring them back, just to remove
> them again in the next fedora release"
> 
> Because of that, this seems to be a WONTFIX. I don't know when he finds time to
> take care of this report, therefore I have put at least this comment in here,
> so you folks know.

great, it's good to know that there will be no way of controlling inhibit on my laptop with Gnome 3.0.

at my work place I am required to have a screensaver switched on - that prevents other people from looking at my screen while I am not at my desk. Occasionally I do presentations, I watch presentations - there the inhibit applet was useful - it prevented my laptop from suspending and my screensaver from blanking out my screen.

Thanks for letting us know about the Gnome 3.0 thing - that's going to be a massive improvement in usability.
Comment 11 Ralph Clark 2011-05-27 09:30:56 EDT
Maintainer: Please fix and restore the inhibit applet to Gnome 2.0. 

It's generally understood that unilaterally dropping features users depend on from a supposedly stable, mature product like Gnome 2.x is inappropriate. This kind of thing makes the Fedora project look like it's not properly managed.

The non-appearance of this applet in Gnome 3.0 is entirely beside the point, by the way. These users are not concerned with Gnome 3.0 right now, and that functionality will need to be restored before Gnome 3.0 will be usable on laptops anyway.
Comment 12 collura 2011-05-27 12:47:26 EDT
some of us are indeed concerned about the usability of gnome3 as well
Comment 13 Noel J. Bergman 2011-05-27 13:27:55 EDT
I will continue to support my replacement inhibit applet on Gnome 2, although I have not found any bugs in it to date.  I encourage anyone who needs inhibit to just use mine, especially since this bug report seems to be a WONTFIX.

As an aside, I, too, am concerned about the Gnome 3's general lack of usability, lack of integration with anything other than JavaScript, and am seriously considering moving to KDE (Plasma) when Gnome 2 is no longer supported on my distros of choice.
Comment 14 Ralph Clark 2011-05-28 09:49:52 EDT
My point about the dropping of this tool from Gnome 3.0 was only that this does _not_ serve as a justification for allowing it to die in Gnome 2, as Gnome 3.0 is hardly complete yet and such missing functionality will need to be replaced before it can be considered to _be_ complete.
Comment 15 Theodore Lee 2011-06-26 01:08:16 EDT
I suppose it's worth noting that the inhibit applet's functionality seems to be available in GNOME 3 in the form of the package gnome-shell-extension-presentation-mode - I haven't had any problems with that so far.
Comment 16 markm 2011-07-19 06:00:06 EDT
gnome-hell does not work for me, it's an usability disaster, hence I cannot use this extension in fall back mode...

I've noticed that whole power management is broken - no dimming, when I disconnect from the power... etc. and apparently gnome 3 was designed with mobile users in mind.