This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 649013

Summary: Fedora 14 SoaS repeatedly prompts for gnome-keyring password at first login
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: sugarAssignee: Peter Robinson <pbrobinson>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 14CC: bernie+fedora, fgrose, johnp, martin, matt, mokurai, pbrobinson, satellitgo, sebastian, simon, smparrish, sridhar+bugs
Target Milestone: ---Keywords: CommonBugs, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: https://fedoraproject.org/wiki/Common_F14_bugs#sugar_keyring
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-11 06:08:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 601827    

Description Adam Williamson 2010-11-02 14:20:42 EDT
When you first boot Fedora 14 SoaS, after entering your name, it pops up the main 'desktop' with a gnome-keyring window over the top asking for a password for the default keyring. If you enter a password, the window comes right back up again. You can never get past it by entering a password; you have to cancel out of it. I didn't check what are the consequences of cancelling out of the window (I'd guess passwords aren't stored in a keyring and you have to enter them over and over again).

This isn't a gnome-keyring bug per se, I don't think, as it doesn't behave this way on Desktop or LXDE spins; it's something to do with the Sugar environment configuration or the SoaS spin configuration.

Tested in a KVM.
Comment 1 Adam Williamson 2010-11-02 14:21:03 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2010-11-02 14:24:08 EDT
Note - this is not 



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2010-11-02 14:24:40 EDT
d'oh. I meant, this is not the same as https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=643435 , though at first glance it may appear similar.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Matt Wronkiewicz 2010-11-02 19:40:33 EDT
See also the report at http://bugs.sugarlabs.org/ticket/2339
Comment 5 satellitgo 2010-11-02 22:45:56 EDT
If you enter the password one time and cancel 6 more times you get past this to the F3 Circular window of sugar. Telepathy gabble on f1 Screen has a related bug: 

wrong names of format xxxxxxxxxx@jabber,sugarlabs.org in f1 telepathy-gabble neighborhood view
http://bugs.sugarlabs.org/ticket/2355#comment:16

you have to change color in Control panel About me then restart. Then Telepathy names are correct IF and ONLY IF you log in with the password you entered one time on startup. (password seems to be stored.)
Comment 6 Frederick Grose 2010-11-13 18:32:13 EST
(In reply to comment #0)
>  
> This isn't a gnome-keyring bug per se, I don't think, as it doesn't behave this
> way on Desktop or LXDE spins; it's something to do with the Sugar environment
> configuration or the SoaS spin configuration.
> 
> Tested in a KVM.

This behavior DOES occur with Fedora 14 Desktop installed from
http://download.fedoraproject.org/pub/fedora/linux/releases/14/Live/x86_64/Fedora-14-x86_64-Live-Desktop.iso followed by software update and Add/Remove Software installation of sugar-emulator.
Comment 7 Peter Robinson 2011-05-07 13:34:49 EDT
We fixed the issue on the F-15 live image by creating a default keyring with the
following bash scriptlet. When we install and a new user is created this script
obviously doesn't run (such as a user with liveinst). I'm not sure how other
desktops create a new keyring for a user if one doesn't exist. Is that
documented anywhere? It might be possible to put a default keyring in
/etc/skel/

if [ ! -e /home/liveuser/.gnome2/keyrings/login.keyring ]; then
mkdir -p /home/liveuser/.gnome2/keyrings
cat >> /home/liveuser/.gnome2/keyrings/login.keyring << FOE
[keyring]
display-name=login
ctime=1302886515
mtime=1302886515
lock-on-idle=false
lock-timeout=0
FOE
chown -R liveuser:liveuser /home/liveuser/.gnome2/keyrings
fi
Comment 8 Peter Robinson 2011-10-11 06:08:16 EDT
Fixed in SoaS v5