Bug 649333

Summary: Unable to boot Fedora 13 guest
Product: [Fedora] Fedora Reporter: Jan ONDREJ <ondrejj>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: akozumpl, amit.shah, berrange, dwmw2, ehabkost, fedora-bugzilla, gcosta, itamar, jaswinder, jforbes, knoel, markmc, miroslav.baranko, ondrejj, sbose, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-23 10:16:06 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
qemu info commands registers and x/30i none

Description Jan ONDREJ 2010-11-03 11:00:30 EDT
Description of problem:
After upgrade of Fedora 13 host to Fedora 14, I can't boot old Fedora 13 qcow2 guests. I use i686 kvm guest. Same problem with f12 guest.

Version-Release number of selected component (if applicable):
qemu-kvm-0.13.0-1.fc14.i686
Fully updated minimal F13 stable guest.

How reproducible:
always, also after reinstall of guest

Steps to Reproduce:
1.install Fedora 13 guest
2.remove "rhgb quiet" from kernel parameters to see more messages
3.boot
  
Actual results:
Probing EDD (edd=off to disable)... ok
_

System stops here. CPU is used by qemu process, but boot does not continue.

Expected results:
System booting.

Additional info:
Also no more messages with "earlyprintk=vga" kernel parameter. Does not matter, if I remove "rhgb quiet" from kernel parameters. How can I debug grub booting?
"edd=off" kernel parameter does not help too.

Same problem running from command line:
qemu-kvm -drive file=fedora-13.img,cache=none,format=qcow2,if=virtio,boot=on -m 1024
But works with qemu (non kvm version), just it's slow.
Comment 1 Miroslav Baranko 2010-11-04 19:23:47 EDT
I have the same problem,

after update host from fedora 13 to fedora 14, my guest (fedora 13, fedora 12) stop working (Probing EDD (edd=off to disable)... ok .)

edd=off dont help :).

i move guest to fedora 13 host for now :(.
Comment 2 Miroslav Baranko 2010-11-04 19:26:19 EDT
one notice:

no my laptop (with Core i5-430M, fedora 13 guest working on fedora 14 hosts).

but on server (Intel(R) Xeon(R) CPU E5440) not.

maybe some special CPU features?

Thanks
Comment 3 Jan ONDREJ 2010-11-09 04:15:49 EST
Created attachment 459049 [details]
qemu info commands registers and x/30i

Looks like this is a complement of bug #650215. Suggested qemu commands are attached. Curious, that when if fails, these commands returns same always and every time same content (same register content and same output, at least for first look).

Can somebody help me to more debug this bug?
Comment 4 Sumit Bose 2010-11-17 03:58:07 EST
I've had the same issues, but using kernel-2.6.35.8-59.fc14.i686.rpm form koji solved them for me.
Comment 5 Justin M. Forbes 2010-11-23 10:05:16 EST
Can you please test with the latest koji f14 kernel and see if that works for you, there is a major issue impacting i686 hosts resolved there.
Comment 6 Miroslav Baranko 2010-11-23 10:08:59 EST
fedora 14 koji kernel solve problem.
Comment 7 Justin M. Forbes 2010-11-23 10:16:06 EST

*** This bug has been marked as a duplicate of bug 650215 ***
Comment 8 Ales Kozumplik 2010-12-15 07:56:11 EST
*** Bug 663087 has been marked as a duplicate of this bug. ***