Bug 649339

Summary: Broken dependency: libopenraw-pixbuf-loader-0.0.8-2.fc14.i686 requires libopenraw = 0:0.0.8-2.fc14
Product: [Fedora] Fedora Reporter: James Laska <jlaska>
Component: mashAssignee: Bill Nottingham <notting>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 14CC: chkr, dcantrell, debarshir, jturner, notting, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: repoclosure_hash:690e53b30cf34b59f034e80270ba671da96fd18d9c4e6ce682d6a8e4c6d8ee82
Fixed In Version: mash-0.5.22-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-30 16:26:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description James Laska 2010-11-03 15:06:41 UTC
Added repo-1 repo from http://download.fedoraproject.org/pub/fedora/linux/releases/14/x86_64/os
Added repo-2 repo from http://download.fedoraproject.org/pub/fedora/linux/updates/14/x86_64
Added repo-3 repo from http://download.fedoraproject.org/pub/fedora/linux/updates/testing/14/x86_64
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 3
   repo-1
   repo-2
   repo-3
Num Packages in Repos: 22343
package: libopenraw-pixbuf-loader-0.0.8-2.fc14.i686 from repo-1
  unresolved deps: 
     libopenraw = 0:0.0.8-2.fc14

Comment 1 James Laska 2010-11-03 19:55:03 UTC
# yum --enablerepo=updates-testing list libopenraw-pixbuf-loader
Available Packages
libopenraw-pixbuf-loader.i686                                     0.0.8-2.fc14                                   fedora         
libopenraw-pixbuf-loader.x86_64                                   0.0.8-4.fc14                                   updates-testing

The problem seems to be that a i686 downlevel package is still in the repo?

Comment 2 Christian Krause 2010-11-08 22:58:28 UTC
I have investigated the issue:

During the F14 release cycle gtk2 was updated from 2.20.x to 2.22.x.
During this change gdk-pixbuf2 was split off into a separate package and
the location of the gdk-pixbuf loaders has changed from:

F13: /usr/lib/gtk-2.0/2.10.0/loaders/
to
F14: /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders

This caused now some strange effects due to the hard-coded paths in the
mash script for creating the x86_64 repository:

>From mash/mash/multilib.py:
            if fnmatch(dirname, '/usr/lib*/gtk-2.0/*/loaders'):
                return True

So in F13 the mash script picked up all i686 packages which provided
gdk-pixbuf loaders.

In F14 the script does not pick them up anymore (because of the changed
path) and so the i686 versions of some loaders are missing in the x86_64
repository.

I have double-checked on fedora-devel that the mentioned gdk-pixbuf loaders should be multilib.

Re-assigning the bug to the mash component to adjust the paths.

Comment 3 Bill Nottingham 2010-11-09 19:53:25 UTC
Fixed in 0.5.20-5.fc15... although it will take a while for it to end up used for updates.

Comment 4 Fedora Update System 2010-11-09 20:40:32 UTC
mash-0.5.20-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mash-0.5.20-6.el5

Comment 5 Fedora Update System 2010-11-10 17:02:55 UTC
mash-0.5.20-6.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mash'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mash-0.5.20-6.el5

Comment 6 Fedora Update System 2010-11-30 16:26:01 UTC
mash-0.5.20-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-06-27 20:29:01 UTC
mash-0.5.22-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mash-0.5.22-1.el5

Comment 8 Fedora Update System 2011-06-27 20:29:41 UTC
mash-0.5.22-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mash-0.5.22-1.el6

Comment 9 Fedora Update System 2011-06-27 20:30:46 UTC
mash-0.5.22-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mash-0.5.22-1.fc14

Comment 10 Fedora Update System 2011-06-27 20:31:37 UTC
mash-0.5.22-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mash-0.5.22-1.fc15

Comment 11 Fedora Update System 2011-07-18 18:33:39 UTC
mash-0.5.22-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-07-18 18:34:11 UTC
mash-0.5.22-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-12-04 02:39:20 UTC
mash-0.5.22-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-12-04 02:48:13 UTC
mash-0.5.22-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.