Bug 652027

Summary: ERROR with rpm_check_debug vs depsolve
Product: Red Hat Enterprise Linux 5 Reporter: Mike McLean <mikem>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED NOTABUG QA Contact: BaseOS QE Security Team <qe-baseos-security>
Severity: medium Docs Contact:
Priority: low    
Version: 5.8   
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-10 16:05:35 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mike McLean 2010-11-10 15:29:58 EST
Description of problem:
This error occurred on a koji test system attempting to initialize an F15 based buildroot. 

ERROR with rpm_check_debug vs depsolve:
rpmlib(FileCaps) is needed by iputils-20101006-3.fc15.x86_64
rpmlib(FileCaps) is needed by policycoreutils-2.0.83-36.fc15.x86_64
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Version-Release number of selected component (if applicable):
yum-3.2.22-26.el5_5.1.noarch

How reproducible:
seems to repeat reliably
Comment 1 seth vidal 2010-11-10 16:05:35 EST
those pkgs require a feature in rpm which your system doesn't offer.

you'll need to rebuild them w/o that rpm feature (File Capabilities)


We've fixed this error msg in more recent yum versions so it doesn't emit it if you have an rpmlib() unresolved dep.