Bug 652124

Summary: F14 + Nvidia + cairo really slow for thunderbird, switching gnome tabs, etc
Product: [Fedora] Fedora Reporter: G. Michael Carter <mikey>
Component: cairoAssignee: Benjamin Otte <otte>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: adler, alekcejk, atigro, grenier, malocascio, mathieu, me, mike, mike.tillberg, natros, nikt, otte, richard.w.jerrido, steven, teoman.onay, timur.kristof, zejdl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-18 05:07:16 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Xorg log file from crash none

Description G. Michael Carter 2010-11-10 22:12:53 EST
I upgraded 3 machines and on the machines with a Nvidia card using NVidia drivers portions of the display are really really slow.  (Intel is unaffected)

Switching tabs on Gnome Terminal take 5 seconds.   Opening Thunderbird really slow switching e-mails or doing anything.  Seems any app that's using the cairo is slow.

I got the hint from http://www.nvnews.net/vbulletin/showthread.php?t=156796

After running: 

yum --releasever=13 downgrade cairo.x86_64 cairomm.x86_64 cairomm-devel cairo-devel


Everything started to run as expected.   There seems to be something wrong with the latest cairo driver in Fedora 14, or at least it doesn't like the Nvidia drivers.

Installed (working):

cairo.x86_64     1.8.10-1.fc13                @fedora/13
cairomm.x86_64   1.8.4-2.fc13                 @updates/13

Not working:

cairo.x86_64     1.10.0-2.fc14                updates
cairomm.x86_64   1.9.2-1.fc14                 fedora
Comment 1 Michael Cronenworth 2010-11-11 09:16:13 EST
In this thread[1] I was pointed to a patch[2] to workaround this.

[1] http://www.nvnews.net/vbulletin/showthread.php?t=156885
[2] http://repos.archlinux.org/wsvn/packages/cairo/trunk/cairo-1.10.0-buggy_gradients.patch
Comment 2 Christophe GRENIER 2010-11-11 12:49:23 EST
My computer is experimenting the same symptom. Downgrading solves this issue.

Other packages may be affected as tvtime is very slow/unusable since fc13 -> fc14 upgrade and this issue isn't fixed by this downgrade.
Comment 3 Timur Kristóf 2010-11-12 08:17:10 EST
The patch on the link Michael Cronenworth gave in Comment 1 worked for me too.
Comment 4 Met Merilius 2010-11-12 17:55:04 EST
I confirm the patch:
> http://repos.archlinux.org/wsvn/packages/cairo/trunk/cairo-1.10.0-buggy_gradients.patch

applied to cairo-1.10.0-2.fc14.src.rpm fixed the problem for me. It also fixed the buggy look of controls (buttons and progress bars) under Nodoka theme.
Comment 5 G. Michael Carter 2010-11-13 22:11:35 EST
Can someone post the instructions on how to patch this?   I usually just try to stick to stock fedora packages but this problems annoying.   I'm finding the downgraded version to be very buggy in my setup.
Comment 6 Stephen Adler 2010-11-14 07:31:05 EST
My fix was to go out and buy an ATI HD 5750 card... (sorry... off topic...)

But I certainly second the motion to push this bug up in priority.
Comment 7 Timur Kristóf 2010-11-14 13:38:30 EST
G. Michael Carter, head on to the forum Michael Cronenworth linked in Comment 1 (his first link). There you can find the instructions on how to do this in the 8th post.

1. Download the .src.rpm and use the rpmbuild (as described in that forum post) to make installable rpms out of it
2. rpmbuild will tell you which directory it put the resulting .rpm in. Go there and use the rpm -Uvh to install those packages. (Also described in the aforementioned forum post.)
Comment 8 Michal Žejdl 2010-11-15 07:02:16 EST
I had terribly slow redrawing of Firefox, Terminal, XChat after upgrading to F14. Downgrading cairo to F13 version returned my desktop to good old behavior.

xorg-x11-drv-nvidia-260.19.12-3.fc14.i686 from RPM Fusion

yum --releasever=13 downgrade cairo --nogpgcheck & Xorg restart = ok
Comment 9 G. Michael Carter 2010-11-15 21:44:15 EST
I've applied the cairo with the patch and my Xorg server has become really really unstable over the past few days.   It keeps flickering to black.  Sometime I get weird triangles over windows as they move (using compiz).   

Recently it completely dies.

I'm looking at the logs now and there's the following messages:

... lots of fixme messages like this
fixme:iphlpapi:SendARP (DestIP 0x08001dac, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
Created new window in existing browser session.

fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0x08001dac, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub

(exe:22948): Gdk-WARNING **: XID collision, trouble ahead

(exe:22948): Gdk-WARNING **: XID collision, trouble ahead

(exe:22948): Gdk-WARNING **: XID collision, trouble ahead

(exe:22948): Gdk-WARNING **: XID collision, trouble ahead

(exe:22948): Gdk-WARNING **: XID collision, trouble ahead

fixme:iphlpapi:SendARP (DestIP 0x08001dac, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:iphlpapi:SendARP (DestIP 0xffffffff, SrcIP 0x00000000, pMacAddr 0x33f434, PhyAddrLen 0x33f43c): stub
fixme:wincodecs:JpegDecoder_Frame_GetResolution (0x1532ac,0x33ed1c,0x33ed14): stub

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x2d) [0x483065]
1: /usr/bin/X (0x400000+0x52cb2) [0x452cb2]
2: /lib64/libc.so.6 (0x7f8d48bcb000+0x340e0) [0x7f8d48bff0e0]
3: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x54ace) [0x7f8d445fface]
4: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x3af276) [0x7f8d4495a276]
5: /usr/bin/X (0x400000+0x4c5d0) [0x44c5d0]
6: /usr/bin/X (miPointerSetPosition+0x182) [0x44d132]
7: /usr/bin/X (GetPointerEvents+0x68b) [0x43aaf2]
8: /usr/bin/X (xf86PostMotionEventP+0x117) [0x4674bb]
9: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f8d42a3a000+0x453f) [0x7f8d42a3e53f]
10: /usr/bin/X (0x400000+0x5a200) [0x45a200]
11: /usr/bin/X (0x400000+0xe0838) [0x4e0838]
12: /lib64/libc.so.6 (0x7f8d48bcb000+0x340e0) [0x7f8d48bff0e0]
13: /lib64/libc.so.6 (__poll+0x18) [0x7f8d48ca5848]
14: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x73bbd) [0x7f8d4461ebbd]
15: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x6c078) [0x7f8d44617078]
16: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0xd01d6) [0x7f8d4467b1d6]
17: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x66c6c) [0x7f8d44611c6c]
18: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x6a816) [0x7f8d44615816]
19: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x6e1f5) [0x7f8d446191f5]
20: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0xa3949) [0x7f8d4464e949]
21: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x3be86c) [0x7f8d4496986c]
22: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x3be9e1) [0x7f8d449699e1]
23: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0xa508f) [0x7f8d4465008f]
24: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0xa578e) [0x7f8d4465078e]
25: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x6cf4e) [0x7f8d44617f4e]
26: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0xd13a1) [0x7f8d4467c3a1]
27: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x3ef48c) [0x7f8d4499a48c]
28: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x3ef5bf) [0x7f8d4499a5bf]
29: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x3deda0) [0x7f8d44989da0]
30: /usr/bin/X (0x400000+0xac02e) [0x4ac02e]
31: /usr/bin/X (miGlyphs+0x567) [0x51a400]
32: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8d445ab000+0x3df1dd) [0x7f8d4498a1dd]
33: /usr/bin/X (0x400000+0xac312) [0x4ac312]
34: /usr/bin/X (0x400000+0xa7965) [0x4a7965]
35: /usr/bin/X (0x400000+0x2b02e) [0x42b02e]
36: /usr/bin/X (0x400000+0x215da) [0x4215da]
37: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f8d48be9e7d]
38: /usr/bin/X (0x400000+0x210a9) [0x4210a9]
Segmentation fault at address 0x300

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

Please consult the Fedora Project support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

nautilus: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
gnome-screensaver: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
Pidgin: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
applet.py: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
parcellite: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
gnote: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
Comment 10 G. Michael Carter 2010-11-15 21:45:07 EST
Created attachment 460715 [details]
Xorg log file from crash
Comment 11 G. Michael Carter 2010-11-15 21:46:09 EST
I really don't know how to read these back traces, and logs so please excuse my ignorance.
Comment 12 Mark Locascio 2010-11-17 00:11:44 EST
I have the same problem. Just upgraded from F12 to F14 (x86_64). I have a nvidia GT220. Installing the proprietary nvidia drivers slows things down quite a bit, and the screen occasionally flickers to black for a second or two. For now, I'm using nouveau, which does not suffer from these problems. But I'll need to use the nvidia drivers sooner or later.
Comment 13 G. Michael Carter 2010-11-17 09:04:19 EST
Is there any way to run the F14 graphics through a full test?   Some program that calls every possible graphics function there is?
Comment 14 Michael Cronenworth 2010-11-17 10:09:42 EST
(In reply to comment #13)
> Is there any way to run the F14 graphics through a full test?   Some program
> that calls every possible graphics function there is?

yum install gtkperf

Run it with 1000 rounds. Ideally you should see a final time of 40 to 60 seconds.
Comment 15 Mark Locascio 2010-11-17 14:48:34 EST
Tried something I read in a forum. I changed the GNOME theme to "Mist," and things run at a normal speed now using the proprietary nvidia driver. However, it still flickered to black for a second earlier today. It only did it once though... yesterday it happened several times.
Comment 16 Teoman ONAY 2010-11-18 03:28:00 EST
Downgrade cairo worked for me.

Like G. Michael Carter said :

yum --releasever=13 downgrade cairo cairomm cairomm-devel cairo-devel
Comment 17 Benjamin Otte 2010-11-18 05:07:16 EST

*** This bug has been marked as a duplicate of bug 649955 ***