Bug 652373

Summary: Cannot boot Fedora 14 on qemu-kvm -smp 2
Product: [Fedora] Fedora Reporter: ardee <robindimi>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 14CC: amit.shah, berrange, clalance, dwmw2, ehabkost, extras-orphan, gcosta, itamar, jaswinder, jforbes, joe, knoel, markmc, notting, ondrejj, quintela, scottt.tw, virt-maint, voidmain_isageek
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-23 10:14:00 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description ardee 2010-11-11 13:12:52 EST
Description of problem:
After upgrading my host to Fedora 14 (using preupgrade) I've been unable to boot a guest OS of Fedora 14 using qemu-kvm when any value other than -smp 1  is specified.

This only occurs when attempting to boot Fedora 14. I can successfully boot e.g. a Fedora 13 Live CD, or FreeBsd.

I have 3 guest OS's (Fedora 14) which were successfully running under Fedora 13, now they will no longer boot after upgrade to Fedora 14.

Version-Release number of selected component (if applicable):
uname -a :
Linux devvirthost 2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

yum info qemu-kvm:
Name        : qemu-kvm
Arch        : x86_64
Epoch       : 2
Version     : 0.13.0
Release     : 1.fc14

How reproducible:
Error occurs every time

Steps to Reproduce:
1. Launch qemu-kvm with the following :
qemu-kvm -M pc-0.13 -smp 2 -m 1024 -cdrom /home/user1/Downloads/Fedora-14-x86_64-Live-Desktop.iso
  
Actual results:
New window with splash screen appears and boot countdown until boot. After countdown expires, window clears and changes to all white. Cpu consumption on a single core on the host goes to 100% and remains there until the window is closed.

Additional info:
CPU on Host is AMD Phenom II, 6 core
Comment 1 Jens Falsmar Oechsler 2010-11-20 16:54:48 EST
I think I have exactly same issue with SMP and KVM. I also run with AMD Opteron/Phenom CPU, apparently they are more prone to mess up :)

Problem is solved with kernel 2.6.35.8-60.fc14.x86_64 for me.

Regards Jens
Comment 2 ardee 2010-11-20 17:50:01 EST
(In reply to comment #1)
> I think I have exactly same issue with SMP and KVM. I also run with AMD
> Opteron/Phenom CPU, apparently they are more prone to mess up :)
> 
> Problem is solved with kernel 2.6.35.8-60.fc14.x86_64 for me.
> 
> Regards Jens

Hiya,

I had pretty much thought that it was probably a kernel related issue, but haven't had the time to build a new kernel to test that out.

>Problem is solved with kernel 2.6.35.8-60.fc14.x86_64 for me.
Is that kernel coming down the main repositories soon?
I'll try that out as soon as it's available and see how well that goes.

Cheers,
rd
Comment 3 Sergei LITVINENKO 2010-11-22 09:25:38 EST
After clean installation of F14 I can not boot virtual machines.
It is worked good under F13, but can not boot under F14, ever command line is very simple:
---
qemu-kvm -localtime -m 640 -name fedora14 -drive fedora14.img
---

[sergeil@homedesk ~]$ rpm -qa | grep qemu
qemu-common-0.13.0-1.fc14.i686
gpxe-roms-qemu-1.0.1-1.fc14.noarch
qemu-system-x86-0.13.0-1.fc14.i686
qemu-kvm-0.13.0-1.fc14.i686

[sergeil@homedesk ~]$ uname -r
2.6.35.6-48.fc14.i686.PAE
Comment 4 Jan ONDREJ 2010-11-22 09:34:51 EST
For anybody, who has still problems, try to use this kernel:

http://koji.fedoraproject.org/koji/buildinfo?buildID=205708

(latest kernel from koji).

Why this kernel is still not at least in updates-testing repository?
Comment 5 Sergei LITVINENKO 2010-11-22 10:09:12 EST
>> http://koji.fedoraproject.org/koji/buildinfo?buildID=205708

It work

>> Why this kernel is still not at least in updates-testing repository?

+1
Comment 6 Void Main 2010-11-22 19:17:02 EST
I had the same problem with the i686 version running on a Phenom 9500 Quad Core. I could not boot the DVD in my VMs until changing them to 1 proc. Updating to the i686 koji kernel linked in the message above seems to have solved the problem. Thanks!
Comment 7 Justin M. Forbes 2010-11-23 10:14:00 EST

*** This bug has been marked as a duplicate of bug 650215 ***