Bug 652435

Summary: Define CMAKE_RC_COMPILER
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: mingw32-filesystemAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: drizt72, erik-fedora, fedora-mingw, kalevlember, laurent.rineau__fedora, rjones
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mingw32-filesystem-63-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-21 21:55:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Orion Poplawski 2010-11-11 20:53:01 UTC
Description of problem:

Please add:

SET(CMAKE_RC_COMPILER /usr/bin/i686-pc-mingw32-windres)

to /usr/share/mingw32/Toolchain-mingw32.cmake

Version-Release number of selected component (if applicable):
mingw32-filesystem-62-2.fc14.noarch

Comment 1 Erik van Pienbroek 2010-11-11 22:37:52 UTC
Looks good enough to me, will push it to f14 and rawhide

Comment 2 Fedora Update System 2010-11-11 22:48:10 UTC
mingw32-filesystem-63-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mingw32-filesystem-63-1.fc14

Comment 3 Fedora Update System 2010-11-13 22:04:14 UTC
mingw32-filesystem-63-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mingw32-filesystem'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mingw32-filesystem-63-1.fc14

Comment 4 Fedora Update System 2010-11-21 21:55:48 UTC
mingw32-filesystem-63-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Laurent Rineau 2011-10-28 14:34:18 UTC
With the commited patch, Orion did you manage to use the RC compiler properly?

After the CMake configuration is done successfully, I have errors like:

/usr/bin/i686-pc-mingw32-windres: can't open `/foCMakeFiles/CGAL.dir/CGAL_verinfo.rc.res' for input

because CMake tries the option /fo (the syntax of Microsoft rc.exe) instead of the option -o (syntax of windres).

And I add also to add the option "-O coff" so that the linker agrees to link with the generated file.

So my patch is:

diff --git a/Toolchain-mingw32.cmake b/Toolchain-mingw32.cmake
index 66ef563..f965ce5 100644
--- a/Toolchain-mingw32.cmake
+++ b/Toolchain-mingw32.cmake
@@ -20,6 +20,8 @@ SET(QT_LIBRARY_DIR ${CMAKE_FIND_ROOT_PATH}/lib)
 
 # set the resource compiler (RHBZ #652435)
 SET(CMAKE_RC_COMPILER /usr/bin/i686-pc-mingw32-windres)
+SET(CMAKE_RC_COMPILE_OBJECT
+    "<CMAKE_RC_COMPILER> <FLAGS> <DEFINES> -O coff -o <OBJECT> <SOURCE>")
 
 # override boost library suffix which defaults to -mgw
 SET(Boost_COMPILER -gcc46)


My packages are:
mingw32-filesystem-64-2.fc14.noarch
cmake-2.8.4-1.fc14.x86_64

Comment 6 Orion Poplawski 2011-10-28 14:50:40 UTC
I think it worked for me at the time.  Was a one shot deal for me.

Comment 7 Laurent Rineau 2011-10-28 14:59:04 UTC
Should I open a new bug or reopen that one?

Comment 8 Orion Poplawski 2011-10-28 15:04:05 UTC
I would open a new one.