Bug 652607

Summary: segfault in nautilus while deleting two archives and two dirs
Product: Red Hat Enterprise Linux 6 Reporter: Vladimir Benes <vbenes>
Component: nautilusAssignee: Tomáš Bžatek <tbzatek>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1CC: fnadge, syeghiay, tpelka, tsmetana
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: nautilus-2.28.4-17.el6 Doc Type: Bug Fix
Doc Text:
Cause: A race condition in async code getting information of a file that is being deleted. Consequence: Ocassional crash occured. Fix: A workaround has been placed, checking for NULL objects. Result: No more crashes.
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-24 06:56:12 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
backtrace from abrt none

Description Vladimir Benes 2010-11-12 05:27:57 EST
Description of problem:
I was deleteing two srpm archives together with their content (two dirs) and nautilus crashed

Version-Release number of selected component (if applicable):

nautilus-2.28.4-15.el6.x86_64

How reproducible:
cannot reproduce now

Steps to Reproduce:
1.download libdrm and ibus-chewing srpms
2.extract them both
3.select both srpms and directories and delete them (shift+del)  
  
Actual results:
crash

Expected results:
no crash

Additional info:
don;t know where the problem can be as I cannot reproduce now.. maybe backtrace can tell you more
Comment 1 Vladimir Benes 2010-11-12 05:28:24 EST
Created attachment 460007 [details]
backtrace from abrt
Comment 3 Tomáš Bžatek 2011-01-14 12:27:20 EST
I think you're seeing a crash in nautilus_file_peek_display_name() though it's
not obvious from the backtrace. Please install debuginfo packages next time :-)

That's bug 664679.

We still didn't have luck in reproducing this issue. Some people report crazy
steps but it never really worked on my machine.
Comment 4 Tomáš Bžatek 2011-01-26 08:17:04 EST
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=602500
Comment 5 Tomáš Bžatek 2011-01-27 05:50:36 EST
Workaround committed upstream, going to include it in RHEL6 as well.

Potential steps leading to reproducer:
 1. for i in `seq 1 8`; do dd if=/dev/zero of=file${i} bs=1M count=400; done
 2. run nautilus --browser
 3. switch left pane to Informations
 4. Ctrl+A, Shift+Delete
 5. press left arrow or randomly select some files, that could trigger the crash. Hit rate is awfully low though.
Comment 9 Florian Nadge 2011-02-01 09:38:32 EST
Please be so kind and add a few key words to the technical note of this
bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks
Comment 10 Florian Nadge 2011-02-01 09:38:32 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:
Comment 11 Tomáš Bžatek 2011-02-07 09:32:59 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,7 @@
-Cause:
+Cause: A race condition in async code getting information of a file that is being deleted.
 
-Consequence:
+Consequence: Ocassional crash occured.
 
-Fix:
+Fix: A workaround has been placed, checking for NULL objects.
 
-Result:+Result: No more crashes.
Comment 20 errata-xmlrpc 2011-08-24 06:56:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1203.html