Bug 652934

Summary: Eclipse missing most perspectives and functionality
Product: [Fedora] Fedora Reporter: Kevin Street <street>
Component: eclipseAssignee: Alexander Kurtakov <akurtako>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: akurtako, ebaron, oliver, overholt, sgehwolf
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-14 16:57:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Kevin Street 2010-11-13 16:01:09 UTC
Description of problem:
Open perspective shows only these perspectives available:
CVS Repository Explorer
Debug
Resource (default)
Team Synchronizing

Many actions do not work eg:
From the welcome page clicking on -
samples - shows an empty page
overview:workplace basics - shows a 404 error
overview:team support - shows a 404 error
what's new - shows a 404 error

Version-Release number of selected component (if applicable):
eclipse-pydev.x86_64 1:1.6.1-1.fc14
eclipse-subclipse.noarch 0:1.6.12-1.fc14                   

Dependency Installed:
eclipse-jdt.x86_64 1:3.6.1-2.fc14
eclipse-platform.x86_64 1:3.6.1-2.fc14
eclipse-rcp.x86_64 1:3.6.1-2.fc14
eclipse-svnkit.noarch 0:1.3.3-5.fc14
eclipse-swt.x86_64 1:3.6.1-2.fc14
icu4j-eclipse.x86_64 1:4.2.1-1.fc14 
tomcat5-jasper-eclipse.noarch 0:5.5.27-7.4.fc12
piccolo2d.noarch 0:1.3-5.fc14                     


How reproducible:
always

Steps to Reproduce:
1. install Eclipse
2. open Eclipse
3. start clicking
  
Actual results:
as above

Expected results:
I want my pydev please.

Additional info:
I initially tried this with the Eclipse install as selected during Fedora 14 install. I've since tried reinstalling both with yum groupremove & groupinstall or rpm -e everything eclipse related and then a minimal install with:
yum install eclipse-pydev eclipse-subclipse
(the above component list is from this last variation)

I've tried starting Eclipse with my Fedora 13 workspace and ~/.eclipse and by deleting both and letting Eclipse start cleanly. 

All variations give the same non-functional Eclipse.

Comment 1 Alexander Kurtakov 2010-11-14 06:56:46 UTC
Can you reproduce with https://admin.fedoraproject.org/updates/eclipse-3.6.1-4.fc14 ?
There are 2 issues fixed - missing dependency and openjdk crasher bug.

Comment 2 Kevin Street 2010-11-14 16:42:23 UTC
Installing the rpms in eclipse-3.6.1-4.fc14 fixes it. In fact just installing tomcat5-jsp-2.0-api in my existing config fixes it also. I already had the -XX:-UseCompressedOops in /etc/eclipse.ini.

Thanks!

Comment 3 Alexander Kurtakov 2010-11-14 16:57:24 UTC
Closing as duplicate.

*** This bug has been marked as a duplicate of bug 650145 ***