Bug 652940

Summary: when filing a bug, "Unspecified" should never be a possible choice for Hardware or OS
Product: [Community] Bugzilla Reporter: Andre Robatino <robatino>
Component: Creating/Changing BugsAssignee: Simon Green <sgreen>
Status: CLOSED NOTABUG QA Contact: tools-bugs <tools-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 4.2CC: ebaak, itamar
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-09 07:21:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andre Robatino 2010-11-13 16:40:33 UTC
Description of problem:
When searching for existing bugs, Bugzilla doesn't consider the OS choice "Unspecified" to be a superset of, say, "Linux", but a disjoint category. When actually filing a new bug, Bugzilla defaults to "Unspecified", but when I search, it defaults to "Linux". This means that recently filed bugs aren't visible which will lead to a lot of duplicate bug reports (I filed one myself today and had to mark it a dupe).

Version-Release number of selected component (if applicable):
Whatever bugzilla.redhat.com is currently using

How reproducible:
always

Steps to Reproduce:
1. File a new bug. The OS defaults to "Unspecified".
2. Search for the bug. The OS defaults to "Linux". I don't know how it chooses this, whether it always happens for bugzilla.redhat.com or whether it's doing some kind of User Agent checking. I also don't know why it doesn't make the same OS choice for bug searching as for bug filing.
  
Actual results:
Bug doesn't show up.

Expected results:
"Linux" should be considered a subset of "Unspecified", which would make the bug visible. In addition, maybe the OS choice should be the same for searching as for filing a new bug.

Comment 1 Andre Robatino 2010-11-13 17:25:03 UTC
Just checked and the same appears to be true for Hardware "Unspecified".

Comment 2 Andre Robatino 2010-11-17 14:25:27 UTC
Thinking about it some more, it makes sense that when filing a bug, the Hardware and OS are Unspecified by default, since one usually doesn't know whether the bug exists on other platforms - there's a good chance, but it's uncertain. And if one searches for bugs on a specific platform, one usually only cares about bugs for that platform. So the current default Hardware and OS values for both searching for and filing bugs make sense. However, when searching for a bug using specific Hardware or OS values, the results should also show bugs filed as Unspecified, since it could be one of those. So the only change necessary is to change the search results when using specific Hardware or OS values to also include bugs filed with Unspecified.

Comment 3 Andre Robatino 2010-11-17 14:57:39 UTC
Thinking about it yet some more, does it ever make sense to file a bug as "Unspecified"? All and Unspecified are analogous to boolean AND and OR, resp. When filing a bug, one knows more than just that it exists on some OS (for example) - one knows that it exists on the specific OS the bug was spotted on. If that's all one knows, the bug should be filed for that specific OS. If one knows that the bug exists for all values of OS, then it should be filed under "All". The same is true for Hardware.

On the other hand, searching for "Unspecified" makes sense, since one may be interested in seeing bugs for any value of the parameter. So I think "Unspecified" should be a valid choice for searching for bugs, but not for filing them.

Comment 4 Jeff Fearn 🐞 2012-05-30 04:42:30 UTC
As part of the recent Bugzilla 4.2 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.

Comment 5 Jeff Fearn 🐞 2012-05-30 04:43:45 UTC
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.

Comment 6 Jeff Fearn 🐞 2012-07-19 05:24:17 UTC
As noted previously, the Bugzilla Team is cleaning up a large number of outstanding issues that have bit rotted. This bug is being closed as there has been no response to that notification.

If you believe this bug is still important please reopen this bug in the NEW status and PM will consider it.

Comment 7 Andre Robatino 2012-07-19 05:29:38 UTC
Reopening and changing Version to 4.2. I don't appear to have the choice of setting the Status to NEW (maybe after it's reopened?).

Comment 8 Andre Robatino 2012-07-19 05:30:32 UTC
There, now I can.

Comment 9 Simon Green 2012-10-09 07:21:38 UTC
(In reply to comment #0)
> Steps to Reproduce:
> 1. File a new bug. The OS defaults to "Unspecified".
> 2. Search for the bug. The OS defaults to "Linux". I don't know how it
> chooses this, whether it always happens for bugzilla.redhat.com or whether
> it's doing some kind of User Agent checking. I also don't know why it
> doesn't make the same OS choice for bug searching as for bug filing.

This will be your configured in your default search options, as they are not the site wide default search options (which is for any OS). Since there are legitimate reason why the OS would be Unspecified, I'm marking this bug as NOTABUG.

You can edit or forget your default search options by going to Preferences -> Saved Searches -> (default query)

  -- simon