Bug 653003

Summary: Should eclipse-callgraph really depend on kernel-devel package?
Product: [Fedora] Fedora Reporter: Syam <get.sonic>
Component: eclipse-callgraphAssignee: Charley Wang <chwang>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: akurtako, chwang, overholt, roland.grunberg, sgehwolf
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-14 06:46:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Syam 2010-11-14 03:02:55 UTC
Description of problem:
I've noticed that eclipse-callgraph is the only package besides systemtap that depends on kernel-devel package. Is this dependency really required?

Further, I've a PAE kernel installed. If this dependency is required, shouldn't it be on kernel-PAE-devel instead?

Comment 1 Alexander Kurtakov 2010-11-14 06:46:17 UTC
Eclipse-callgraph doesn't depend on kernel-devel directly but it needs systemtap to work thus the dependency is there?
See 
http://pkgs.fedoraproject.org/gitweb/?p=eclipse-callgraph.git;a=blob;f=eclipse-callgraph.spec;h=5e7afe3fccd036154579afd0a2b6085816c551cd;hb=40d7f8b095d6f0b2cc513bdb48a6eda3d0d2af97 .
I'm going to close the bug as notabug because eclipse-callgraph is based on systemtap and kernel-devel is installed as a dependency of systemtap.
Please reopen the bug against systemtap about your kernel-PAE-devel problem, thought according to systemtap.spec this is the right thing to do.
From http://pkgs.fedoraproject.org/gitweb/?p=systemtap.git;a=blob;f=systemtap.spec;h=972068a4184f5efc46d9824861be05d94b671a9e;hb=3031bf90d69074730f9e9b94baa902f06ae24fe4 :
# Alternate kernel packages kernel-PAE-devel et al have a virtual
# provide for kernel-devel, so this requirement does the right thing.