This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 653436

Summary: xkbcomp fails to compile keymap (s390x)
Product: [Fedora] Fedora Reporter: Karsten Hopp <karsten>
Component: xorg-x11-xkb-utilsAssignee: Peter Hutterer <peter.hutterer>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: high    
Version: 14CC: dan, jstodola, xgl-maint
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: s390x   
OS: Unspecified   
Whiteboard:
Fixed In Version: xorg-x11-xkb-utils-7.5-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-27 18:35:34 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 467765    

Description Karsten Hopp 2010-11-15 08:08:53 EST
Description of problem:
tigervnc runs xkbcomp during initialisation and that fails on s390x:
# Xvnc :1

Xvnc TigerVNC 1.0.90 - built Nov 15 2010 06:55:22
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 Constantin Kaplinsky
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 10900000, The X.Org Foundation


Mon Nov 15 07:59:32 2010
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5901
 vncext:      created VNC server for screen 0
syntax error: line 8 of stdin
Errors encountered in stdin; not compiled.
(EE) Error compiling keymap (server-1)
(EE) XKB: Couldn't compile keymap
XKB: Failed to compile keymap
Keyboard initialization failed. This could be a missing or incorrect setup of xkeyboard-config.

Fatal server error:
Failed to activate core devices.


I get a similar error with the following, not sure if that is related:
# setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwertz)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+de+us:2+inet(evdev)+terminate(ctrl_alt_bksp)"       };
        xkb_geometry  { include "pc(pc104)"     };
};

# setxkbmap -print > /tmp/xkbmap
# xkbcomp /tmp/xkbmap
syntax error: line 8 of .xkbmap
last scanned symbol is: pc
Errors encountered in .xkbmap; not compiled.



Version-Release number of selected component (if applicable):
xorg-x11-xkb-utils-7.4-9.fc14.s390x

How reproducible:
every time

Steps to Reproduce:
1. Xvnc :1
  
Actual results:
No core devices detected as xkbcomp fails


Additional info:
this is blocking GUI installs on s390x (F-14) where VNC is the only option for GUI installs.
Comment 1 Matěj Cepl 2010-11-15 19:06:45 EST
Could somebody suggest me some machine where I could play with reproduction of this a little bit more? Whatever source of test machines I can find seems to be severely short on s390x with Fedora.
Comment 3 Matěj Cepl 2010-11-17 05:47:04 EST
Yes, can fully reproduce and I don't see anything obvious why it shouldn't work.

jakoubek:~ $ ssh -Y testmachine 
Last login: Wed Nov 17 04:51:11 2010 from vpn1-6-71.ams2.redhat.com
/usr/bin/xauth:  creating new authority file /home/mcepl/.Xauthority
[mcepl@fedora3 ~]$ setxkbmap -print 
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+cz(qwerty)+us:2+inet(evdev)+altwin(alt_super_win)+group(shifts_toggle)+ctrl(nocaps)+compose(rctrl)+nbsp(none)+terminate(ctrl_alt_bksp)"	};
	xkb_geometry  { include "thinkpad(intl)"	};
};
[mcepl@fedora3 ~]$ setxkbmap -print >kbmap
[mcepl@fedora3 ~]$ xkbcomp kbmap 
syntax error: line 8 of kbmap
last scanned symbol is: thinkpad
Errors encountered in kbmap; not compiled.
[mcepl@fedora3 ~]$ ls /usr/share/X11/xkb/geometry
amiga         everex   chicony    microsoft  pc        sun
ataritt       fujitsu  keytronic  nec        README    thinkpad
dell          hhk      kinesis    nokia      sgi_vndr  typematrix
digital_vndr  hp       macintosh  northgate  sony      winbook
[mcepl@fedora3 ~]$ ls /usr/share/X11/xkb/symbols
ad        compose       gn       kpdl            mv          si
af        ctrl          gr       kr              nbsp        sk
al        cz            group    kz              nec_vndr    sn
altwin    de            hp_vndr  la              ng          sony_vndr
am        digital_vndr  hr       latam           nl          srvr_ctrl
ara       dk            hu       latin           no          sun_vndr
az        ee            ch       level3          nokia_vndr  sy
ba        empty         ie       level5          np          terminate
bd        epo           il       lk              olpc        th
be        es            in       lt              pc          tj
bg        et            inet     lv              pk          tm
br        eurosign      iq       ma              pl          tr
brai      extras        ir       macintosh_vndr  pt          typo
bt        fi            is       mao             ro          tz
bw        fo            it       me              rs          ua
by        fr            jp       mk              ru          us
ca        fujitsu_vndr  ke       ml              rupeesign   uz
capslock  gb            keypad   mm              se          vn
cd        ge            kg       mn              sgi_vndr    xfree68_vndr
cn        gh            kh       mt              shift       za
[mcepl@fedora3 ~]$ strace -f -o xkbcomp-strace.txt xkbcomp -R/usr/share/X11/xkb/ ~/kbmap 
syntax error: line 8 of /home/mcepl/kbmap
last scanned symbol is: thinkpad
Errors encountered in /home/mcepl/kbmap; not compiled.
[mcepl@fedora3 ~]$ xkbcomp -R/usr/share/X11/xkb/ ~/kbmap "$DISPLAY"
syntax error: line 8 of /home/mcepl/kbmap
last scanned symbol is: thinkpad
Errors encountered in /home/mcepl/kbmap; not compiled.
[mcepl@fedora3 ~]$
Comment 4 Matěj Cepl 2010-11-17 05:51:36 EST
GUI installation is important because of lack of advanced configuration tools (important for S/390x).
Comment 5 Karsten Hopp 2010-11-18 09:52:26 EST
*** Bug 651475 has been marked as a duplicate of this bug. ***
Comment 6 Karsten Hopp 2010-11-22 12:29:59 EST
This failure is caused by the xkbcomp-speed.patch, xorg-x11-xkb-utils-7.5-1 works, xorg-x11-xkb-utils-7.4-9 without this patch works
Comment 7 Fedora Update System 2010-11-22 13:18:35 EST
xorg-x11-xkb-utils-7.5-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-xkb-utils-7.5-1.fc14
Comment 8 Fedora Update System 2010-11-23 16:56:33 EST
xorg-x11-xkb-utils-7.5-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-xkb-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-xkb-utils-7.5-1.fc14
Comment 9 Fedora Update System 2010-11-27 18:35:29 EST
xorg-x11-xkb-utils-7.5-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.