Bug 653447

Summary: footnote in <biblioentry> generates two entries in html
Product: [Community] Publican Reporter: Klaus.Malorny
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 2.3CC: jfearn, mmcallis, publican-list, r.landmann, sradvan
Target Milestone: 3.2   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: 3.2.0 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-08-09 00:47:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Screenshot showing the effect
XSL style sheets that came with Publican 2.3 none

Description Klaus.Malorny 2010-11-15 08:44:06 EST
This bug applies to publican 2.3, at least for the html-single format (others not tested)

Description of problem:

A footnote in an element within a <biblioentry> causes the footnote to appear twice. This is the causing DocBook fragment:

    <biblioentry id="Unicode">
      <title>The Unicode Standard<footnote><para>No version is given here,
        as this standard evolves over time. At the time of writing,
        the latest version was 6.0</para></footnote></title>
      <publisher><publishername>The Unicode
      <biblioid class="uri">http://www.unicode.org</biblioid>
Comment 1 Jeff Fearn 2010-11-21 18:04:15 EST
Hi, I can't duplicate this behaviour on F14, can you tell us what version of the DocBook DTD and styles you are using?
Comment 2 Klaus.Malorny 2010-11-25 03:33:51 EST
Created attachment 462841 [details]
Screenshot showing the effect
Comment 3 Klaus.Malorny 2010-11-25 03:35:49 EST
Created attachment 462843 [details]
XSL style sheets that came with Publican 2.3
Comment 4 Klaus.Malorny 2010-11-25 03:48:57 EST
I don't see any CVS version tags or similar in the style sheets, so I simply attached them to this bug report. I am using DocBook 4.5. As I am using Ubuntu, I downloaded Publican from the repository of the upcoming 11.04 version ("natty"), as the current release for Unbuntu 10.10 is still 1.6.3. The version tag is "2.3-1ubuntu1", whatever this means.

I also attached a small screenshot, depicting the problem. I am using my own branding (still not perfect), but should not have any effect on the structure of the HTML file as far as I understand the whole system.

The problem does not occur with the multi-page ("html") format, by the way. The document that causes the problem is not that secret, but I don't want to make it public via Bugzilla. So if I had an e-mail address, I could supply the document if need be.
Comment 6 Ruediger Landmann 2013-07-14 22:44:07 EDT
I can reproduce this on F19, but not in html-single; only in multi-page HTML. Updating subject accordingly.
Comment 7 HSS Product Manager 2013-07-16 01:18:36 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 8 Jeff Fearn 2013-07-16 23:50:04 EDT
To ssh://git.fedorahosted.org/git/publican.git
   f493597..4654b5a  HEAD -> devel
Comment 9 Scott Radvan 2013-07-21 22:44:26 EDT
footnote appears once in all formats

verified with publican-3.1.5-0.fc19.t62.noarch
Comment 10 Jeff Fearn 2013-08-09 00:47:44 EDT
The fix for this bug has been shipped in publican 3.2.0