Bug 653550

Summary: update-gio-modules script doesn't work
Product: [Fedora] Fedora Reporter: Edward Sheldrake <ejsheldrake>
Component: glib2Assignee: Matthias Clasen <mclasen>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: cristian.ciupitu, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-14 22:41:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Edward Sheldrake 2010-11-15 17:10:28 UTC
Description of problem:
The update-gio-modules script in /usr/bin/ is installed without execute permissions.

Version-Release number of selected component (if applicable):
glib2-2.26.0-2.fc14

How reproducible:
Always

Steps to Reproduce:
1. ls -l /usr/bin/update-gio-modules
2.
3.
  
Actual results:
-rw-r--r-- 1 root root 319 Sep 30 19:59 /usr/bin/update-gio-modules

Expected results:
-rwxr-xr-x 1 root root 319 Sep 30 19:59 /usr/bin/update-gio-modules

Additional info:

Comment 1 Edward Sheldrake 2010-11-16 12:56:35 UTC
There's more: the update-gio-modules script doesn't actually work even if it is executable.

The script tests the value of $host but never sets the host variable to anything, so always runs /usr/bin/gio-querymodules-32.

Comment 2 Matthias Clasen 2010-11-16 13:17:02 UTC
Hmm, it certainly is 755 on this (rawhide) machine. 
The host thing is a bug, certainly, but the script probably still works ok in %%post, which is the only place where it is likely to be used, since rpm puts host in the environment.

Comment 3 Edward Sheldrake 2010-11-16 13:40:00 UTC
The 755 permissions got fixed in rawhide from some autoqa according to the log, these were applied to the F-14 branch but then reverted due to being comitted to the wrong branch.

I just experimented with printenv and echo $host in a %post scriptlet and it doesn't seem to be set.

Comment 4 Matthias Clasen 2010-11-16 13:51:04 UTC
I'm actually in favour of getting rid of this script and just doing
gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
in %post.

I need to write up a proposal for the packaging guidelines for that.

Comment 5 Cristian Ciupitu 2010-12-25 19:14:02 UTC
libxml2 seems to be affected by this bug:

  Erasing        : libxml2-2.7.7-2.fc14.i686             4/8 
/var/tmp/rpm-tmp.wI3GUq: line 2: gio-querymodules-32: command not found
warning: %postun(glib2-2.26.0-2.fc14.i686) scriptlet failed, exit status 127

Comment 6 Matthias Clasen 2011-04-14 22:41:45 UTC
update-gio-modules is gone in F15