Bug 65520

Summary: Python, pygtk, pygnome incompatibilities
Product: [Retired] Red Hat Raw Hide Reporter: Alexander Farley <afarley>
Component: pythonAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-05-26 19:51:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Alexander Farley 2002-05-26 19:51:45 UTC
Description of Problem:
The pygtk-0.6.9-3 and pygnome-1.4.2-3 packages are incompatible with
python-2.2.1 packages leading to the failure of several programs that rely on
python and the gnome-python packages (i.e. Pintconf, Hardware browser,
serviceconf, etc.; essentially those packages that use python and glade to
create a gui).  Part of the problem is that pygtk and pygnome are compiled for
python-1.5 and not python-2.2, and thus are not put into the
python2.2/site-packages directory.  Mandrake's packages are compiled for
python-2.2, but result in similar errors.

Version-Release number of selected component (if applicable):
python-2.2.1-x
pygtk-0.6.9-3
pygnome-1.4.2-3


How Reproducible:
1005


Steps to Reproduce:
1. Try to execute any package that use the gtk and glade python bindings.
2. Failure to execute to program.

3. For printconf the trace given is (I have installed Mandrake's pygtk and
pygnome,  but almost same trace as without the packages):
Traceback (most recent call last):
  File "/usr/sbin/printtool", line 7, in ?
    import printconf_gui
  File "/usr/share/printconf/util/printconf_gui.py", line 89, in ?
    import gtk, gnome.ui, libglade, gnome.xmhtml
  File "/usr/lib/python2.2/site-packages/libglade.py", line 11, in ?
    class GladeXML(_gtk.GtkData):
AttributeError: 'module' object has no attribute 'GtkData'

For serviceconf the trace is:
Traceback (most recent call last):
  File "/usr/share/serviceconf/serviceconf.py", line 25, in ?
    import gnome.ui
  File
"/home/mrnet/rpm/tmp/pygnome-1.4.2-root/usr/lib/python2.2/site-packages/gnome/ui.py",
line 16, in ?
AttributeError: 'module' object has no attribute '_obj2inst'


Actual Results:
The various programs dependent on python, pygtk, pygnome etc. fail to open.

Expected Results:
The various programs open.


Additional Information:
When I installed the 7.3 packages which are all compiled for python-1.5, the
programs work perfectly.
I do not know enough about python to fix the problems, but the references to the
classes in the files are usually present even though the system says that they
are not.

Comment 1 Bill Nottingham 2002-06-21 04:53:43 UTC
Fixed in current rawhide, in essence, as GNOME 1.4 python bindings are not there.