Bug 655549

Summary: ipa-server-install fails to start certmonger on Fedora 14
Product: [Fedora] Fedora Reporter: Florin Iucha <florin>
Component: certmongerAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: dpal, jgalipea, nalin, rcritten
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-22 16:44:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Florin Iucha 2010-11-21 16:11:40 UTC
Description of problem:
ipa-server-install fails to start certmonger on Fedora 14

Version-Release number of selected component (if applicable):
ipa-server-1.9.0.pre5-0.fc14.x86_64
certmonger-0.30-4.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install ipa-server
2. ipa-server-install
3.
  
Actual results:
  ...
  [13/25]: configuring modrdn plugin
  [14/25]: creating indices
  [15/25]: configuring ssl for ds instance
Unexpected error - see ipaserver-install.log for details:
 Command '/sbin/service certmonger start ' returned non-zero exit status 1

Expected results:


Additional info:
Manually attempting to start certmonger fails with the same error.  There is no indication of the error in the server logs.

Comment 1 Rob Crittenden 2010-11-22 15:17:46 UTC
This sounds like a problem with certmonger.

Do you get any SELinux AVCs when trying to start the certmonger service (/var/log/audit/audit.log)?

Comment 2 Florin Iucha 2010-11-22 16:22:09 UTC
I am not getting any entries in /var/log/audit/audit.log when I run 'service certmonger start'.  Not there and not in any other log.

Comment 3 Florin Iucha 2010-11-22 16:44:37 UTC
At Rob's suggestion I have traced the startup and found this:

connect(7, {sa_family=AF_FILE, path="/var/run/dbus/system_bus_socket"}, 33) = -1 ENOENT (No such file or directory)

which means that certmonger failed to start because messagebus was not running.

I have re-enabled message bus and started up the process and now certmonger starts as well.

The bug can be closed (although a bug shall be reopened against certmonger so it properly logs why it fails to start).

Comment 4 Dmitri Pal 2010-11-23 04:01:16 UTC
It is a known certmonger issue.