Bug 656446

Summary: BackendException: Boto requires a bucket name.
Product: [Fedora] Fedora EPEL Reporter: Ray Van Dolson <rayvd>
Component: python-botoAssignee: Robert Scheck <redhat-bugzilla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: el5CC: redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-boto-1.9b-6.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-01 00:00:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ray Van Dolson 2010-11-23 18:44:43 UTC
Description of problem:
Using duplicity to manage backups to S3, the following error is received:

  BackendException: Boto requires a bucket name.

It appears this is an issue with boto and is fixed in a later release[1].

Version-Release number of selected component (if applicable):
duplicity-0.6.10-1.el5
python-boto-1.0a-1.el5


How reproducible:
Always

Steps to Reproduce:
1. Install duplicity (from epel-testing) and python-boto.
2. Attempt to do a backup to an existing backup on S3.
  
Actual results:

Error above.

Expected results:

Backup proceeds normally.

Additional info:

The launchpad bug mentioned above[1] indicates a newer version of boto fixes the problem.  I don't know which code change in particular would do the trick as to make it trivial to backport the fox to the 1.0.x version.

If there are no other dependencies on python-boto, it might be worth rebasing to 2.x or at least to where EL6 is.

[1] https://bugs.launchpad.net/duplicity/+bug/655468

Comment 1 Ray Van Dolson 2010-11-23 18:47:11 UTC
Note that downgrading to duplicity-0.6.08b-1.el5 is another workaround.  Presumably, this version of duplicity doesn't make use of newer features in python-boto.

Either we shouldn't upgrade duplicity, should revert some of the newer changes in duplicity that break compatibility with python-boto 1.0.x, or should upgrade python-boto.

(It looks like you're also the EPEL maintainer of duplicity)

Comment 2 Robert Scheck 2010-12-09 08:05:13 UTC
I'm going to prepare a python-boto update for EL-5, soon. If I let you know,
will you be able to test this python-boto update a lot?

Comment 3 Ray Van Dolson 2010-12-09 12:39:01 UTC
Absolutely.  Should I test via the latest duplicity you pushed to testing as well?

Comment 4 Fedora Update System 2011-01-02 23:24:38 UTC
python-boto-1.9b-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-boto-1.9b-6.el5

Comment 5 Robert Scheck 2011-01-02 23:30:37 UTC
Please test duplicity-0.6.11-1.el5 and python-boto-1.9b-6.el5 together and
add positive karma to both, if it works for you. Thank you.

Comment 6 Fedora Update System 2011-01-03 17:32:19 UTC
python-boto-1.9b-6.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-boto'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-boto-1.9b-6.el5

Comment 7 Fedora Update System 2011-02-28 23:59:48 UTC
python-boto-1.9b-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.