Bug 656714

Summary: Please Update Spec File to use %ghost on files in /var/run and /var/lock
Product: [Fedora] Fedora Reporter: Lennart Poettering <lpoetter>
Component: uucpAssignee: Nils Philippsen <nphilipp>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: nphilipp, ovasik
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-25 08:16:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 827166    

Description Lennart Poettering 2010-11-23 23:45:22 UTC
Your package uucp appears to include a file in /var/run or /var/lock. With an upcoming change in Rawhide these directories will now be mounted as tmpfs. For details about this change please consult http://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html For your package this means that you need add %ghost to all files that are placed in either of these two directories. Please make sure to make this change in time for the F15 cycle. For details about %ghost see http://www.rpm.org/max-rpm-snapshot/s1-rpm-inside-files-list-directives.html#S3-RPM-INSIDE-FLIST-GHOST-DIRECTIVE , for more information on the F15 feature see the feature page https://fedoraproject.org/wiki/Features/var-run-tmpfs . If your package already uses %ghost on these files, feel free to close this bug report right-away. Sorry for this mass bug filing, and if you have any further questions, don't hesitate to ask on fedora-devel or ask me personally. Thank you, Lennart

Comment 1 Nils Philippsen 2010-11-24 10:46:29 UTC
The uucp package has its own /var/lock/uucp directory, with ownership appropriately set. I'll %ghost it in the file list and add a file to /etc/tmpfiles.d which installs this directory at bootup.

Comment 2 Nils Philippsen 2010-11-24 15:02:27 UTC
I just discussed this briefly with Kay Sievers and Petr Lautrbach on IRC: For a directory it should be sufficient to leave it as it is in %files (specifically: no %ghost) and add a file to /etc/tmpfiles.d so it gets created again during bootup. This does the right thing (because RPM only verifies owner, group, permissions on directories) and is much simpler than having to create them in scriptlets (as would be the case if you used %ghost). Mind that this only applies to directories, not files -- these would either have to be %ghost-ed or moved to a different location (if not volatile).

Lennart, do you agree?

Comment 3 Nils Philippsen 2010-11-25 08:16:40 UTC
Should be fixed in uucp-1.07-24.fc15.