This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 656774

Summary: dhclient-4.1.1-27.P1 breaks wireless?
Product: [Fedora] Fedora Reporter: Jim Haynes <jhhaynes>
Component: dhcpAssignee: Jiri Popelka <jpopelka>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: jpopelka
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-25 04:28:37 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jim Haynes 2010-11-23 22:48:32 EST
Description of problem: I'm visiting a friend who has a wireless access point,
unsecured.  I have two laptops, one a i686 model with F13 installed, and an
x86_64 with F13 installed in one partition and F14 installed by upgrading from
F12 on a second partition.  I applied updates to the two F13 systems and now
cannot get the wireless network up on those systems.  I haven't let F14 update
dhclient yet for fear it will break networking.


Version-Release number of selected component (if applicable):
dhclient-4.1.1-27.P1.fc13  i686 and x86_64 versions

How reproducible:
Seems to be completely reproducible

Steps to Reproduce:
1.I bring up the networking by hand with
   ifconfig wlan0 UP
   iwconfig wlan0 essid "friend's essid"
   dhclient wlan0
2.
3.
  
Actual results:Using dhclient -v wlan0
Listening on LPF/wlan0/00:22:5f:7e:5f:42
Sending on (same as above)
Sending on Socket/fallback
DHCPREQUEST on wlan0 to 255:255:255:255 port 67

On the system that works, this is followed by
DHCPACK from 192.168.2.1
bound to 192.168.2.103

On the systems that do not work this is followed by
DHCPNAK from 192.168.2.1
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
send_packet: Network is down

On the i686 system I attempted to remove and replace dhcp with the
old package from the original distribution and it was apparently
successful and I was able to get the network up.  But I couldn't get
this to work on the x86_64 F13 system.

The F14 system that is still working has pending updates for dhcp and
some NetworkManager packages.

Expected results:


Additional info: I think the wireless router is Linksys
Comment 1 Jiri Popelka 2010-11-24 09:46:17 EST
(In reply to comment #0)
> Description of problem: I'm visiting a friend who has a wireless access point,
> unsecured.  I have two laptops, one a i686 model with F13 installed, and an
> x86_64 with F13 installed in one partition and F14 installed by upgrading from
> F12 on a second partition.  I applied updates to the two F13 systems and now
> cannot get the wireless network up on those systems.  I haven't let F14 update
> dhclient yet for fear it will break networking.
Do you remember if you had updated from the previous version, i.e. from dhclient-4.1.1-26.P1.fc13 or from something even earlier ?
dhclient-4.1.1-27.P1.fc13 was only a security update for DHCPv6 server so the dhclient was actually not changed between 4.1.1-26.P1 and 4.1.1-27.P1.

I need you to do some investigation.
From this page
https://koji.fedoraproject.org/koji/packageinfo?packageID=305
you can download every older dhclient build.
It would be great if you could discover which version of dhclient is the first "problematic" one.
The procedure could be something like:
1) download e.g. dhclient-4.1.1-13.fc13.i686.rpm
2) install it with 'rpm -Uvh --force dhclient-4.1.1-13.fc13.i686.rpm'
3) verify it's working
4) download e.g. dhclient-4.1.1-26.P1.fc13.i686.rpm
5) install it and verify it's not working
6) download some other dhclient version and test if it's working or not
Remember you can always install the one that you already verified as working.

> On the systems that do not work this is followed by
> DHCPNAK from 192.168.2.1
> DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
> send_packet: Network is down
This looks like the router sent (from whatever reason) NAK and dhclient correctly moved to INIT state where it tried to send DISCOVER but was unsuccessful because the interface was down.
Dhclient sets the interface down to delete routes and clear arp cache.
It also sets it back up but this doesn't work (don't ask me why) on some devices (see bug #574568). So I removed the 'setting device down' in dhclient-4.2.0-8.fc14 (F14 only, no F13). So if this is also your problem (not sure with that) then the newer dhclient in F14 should be ok.

> The F14 system that is still working has pending updates for dhcp and
> some NetworkManager packages.
You can also first download (so you can always install it from downloaded rpm) the version that you know is working and then try some newer versions to discover which one (if there's such) breaks.
Comment 2 Jim Haynes 2010-11-24 11:58:13 EST
Thanks.  I had not tested the previous version because I don't have a wireless
I can connect to when I'm at home.  Thanks for the pointer to the older versions,
I will download some of them and try them.  I don't really want to fiddle with
the F14 installation since that is the only one that is working right now - if
I lose that I lose connectivity until I get back home.  So give me a day or two
to try some of this.

BTW I tried to rpm -e the dhclient package in the i686 F13 machine before
installing the older version, and there were just too many dependencies.
So I did the rpm -ivh --force and that worked - on that machine.  But it
hasn't seemed to work on the x86_64 F13 machine, but maybe I didn't do it
right and need to try again.
Comment 3 Jiri Popelka 2010-11-24 12:10:26 EST
(In reply to comment #2)
> So give me a day or two to try some of this.
At the moment you are the only one seeing this problem, so it's your itch :-)
 
> BTW I tried to rpm -e the dhclient package in the i686 F13 machine before
> installing the older version, and there were just too many dependencies.
> So I did the rpm -ivh --force and that worked - on that machine.  But it
> hasn't seemed to work on the x86_64 F13 machine, but maybe I didn't do it
> right and need to try again.
I always use 'rpm -Uvh --force dhclient-n-v-r.rpm'
Comment 4 Jim Haynes 2010-11-24 14:59:19 EST
So today I tried all the dhclient from koji on the F13 x86_64 system and they
all worked, and I let the F14 x86_64 system update completely and it works
(dhclient 4.2.0-14P1)

So please close the bug, excuse me all to hell for bringing it up, must have
been having a bad router day yesterday.
Comment 5 Jiri Popelka 2010-11-25 04:28:37 EST
(In reply to comment #4)
> So please close the bug, excuse me all to hell for bringing it up, must have
> been having a bad router day yesterday.
No problem, I'm glad to hear that.
If it occurs again feel free to reopen this bug and attach wireshark (network traffic analyzer) packet dump from the unsuccessful try.