Bug 656849

Summary: libproxy-mozjs needs to be manually removed
Product: [Fedora] Fedora Reporter: Paul Bolle <pebolle>
Component: libproxyAssignee: Nicolas Chauvet (kwizart) <kwizart>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: jskala, kwizart, nathaniel
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-24 11:19:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Bolle 2010-11-24 10:43:39 UTC
Description of problem:
libproxy-mozjs needs to be manually removed

Version-Release number of selected component (if applicable):
0.4.5-2 (and above)

How reproducible:
Always

Steps to Reproduce:
1. try to upgrade a fairly recent rawhide system
2.
3.
  
Actual results:
various yum dependency problems (output not copy pasted)

Expected results:
no such problems

Additional info:
0) It seems that libproxy-mozjs is not provided any more as of libproxy-0.4.5-2.fc15. libproxy-mozjs has subsequently been removed from the rawhide repositories.

1) The way this update was done left libproxy-mozjs-0.4.4-7.fc14 (or earlier) untouched if it was already installed. Since libproxy-mozjs required libproxy that broke the update. The only workaround seemed to be to manually remove libproxy-mozjs.

2) I suppose a better solution is to have libproxy "provide" (a higher version of) libproxy-mozjs itself, but virtually, not as an actual part of the package. (Maybe a "require" libproxy-mozjs is also needed. I don't know, as this is a rather advanced rpm hack.)

That way a future update of libproxy should automatically remove libproxy-mozjs and solve this dependency problem.

Comment 1 Paul Bolle 2010-11-24 11:04:24 UTC
> 2) I suppose a better solution is to have libproxy "provide" (a higher version
> of) libproxy-mozjs itself, but virtually, not as an actual part of the package.
> (Maybe a "require" libproxy-mozjs is also needed. I don't know, as this is a
> rather advanced rpm hack.)

Reading though bug #190116, I guess a combination of
    Obsolete: libproxy-mozjs < %{version}-%{release}
and
    Provides: libproxy-mozjs = %{version}-%{release}
seems to be needed.

Comment 2 Nicolas Chauvet (kwizart) 2010-11-24 11:19:59 UTC
Fixed in libproxy-0.4.6-3.fc15,
It will be available on next push.
Thx for the report.