Bug 657896

Summary: Yelp does not launch.
Product: [Fedora] Fedora Reporter: Mark <fc_mark>
Component: yelpAssignee: Matthew Barnes <mbarnes>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 14CC: mbarnes
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-28 15:21:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mark 2010-11-28 11:22:53 EST
I just upgraded (fresh install) to Fedora 14 from F13.  Yelp worked in F13, now, it doesn't launch.  I have tried launching it from the terminal and I receive the following traceback information/errors:

[code]
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site.py", line 553, in <module>
    main()
  File "/usr/lib64/python2.7/site.py", line 536, in main
    known_paths = addsitepackages(known_paths)
  File "/usr/lib64/python2.7/site.py", line 315, in addsitepackages
    addsitedir(sitedir, known_paths)
  File "/usr/lib64/python2.7/site.py", line 188, in addsitedir
    addpackage(sitedir, name, known_paths)
  File "/usr/lib64/python2.7/site.py", line 158, in addpackage
    exec line
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/abrt_exception_handler.py", line 28, in <module>
    import subprocess
  File "/usr/lib64/python2.7/subprocess.py", line 428, in <module>
    import select
ImportError: /usr/lib64/python2.7/lib-dynload/selectmodule.so: undefined symbol: _Py_ZeroStruct
[/code]
Comment 1 Mark 2010-11-28 11:29:38 EST
I reported this bug against Gnome here: https://bugzilla.gnome.org/show_bug.cgi?id=635969 and was directed to report it to Fedora.
Comment 2 Mark 2010-11-28 15:21:12 EST
After googling the whole stinking error.  I found that xulrunner-python was the culprit.  I remove it and yelp works as before.