Bug 658228

Summary: mount.fuse seems to ignore mount options
Product: [Fedora] Fedora Reporter: Adalbert Prokop <adalbert.prokop>
Component: pam_mountAssignee: Till Maas <opensource>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: 14CC: jengelh, opensource, rs, steve
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-10 21:00:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 648173    
Bug Blocks:    

Description Adalbert Prokop 2010-11-29 17:59:53 UTC
Description of problem:
I use fuse-encfs and pam_mount to mount my home directory. Currently I have the following problem: If I define the "allow_other" option it seems to be ignored, as well as "nonempty". The user's directory is mounted but no one else can access it.
The "allow_other" option is present in /etc/fuse.conf

Version-Release number of selected component (if applicable):
fuse-2.8.5-2.fc14.i686
pam_mount-2.5-1.fc14.i686

Steps to Reproduce:
1. Create encfs encryption layer from /tmp/a to /tmp/b using test user's login password and unmount it (fusermount -u /tmp/b) afterwards.

2a. Preparte pam_mount (I've only listed important entries)
<debug enable="1" />
<mntoptions allow="nosuid,nodev,loop,encryption,fsck,nonempty,allow_root,allow_other,default_permissions" />
<volume user="user" fstype="fuse" path="encfs#/tmp/a" mountpoint="/tmp/b" options="default_permissions,allow_other" />

3a. Login as test user (here: "user").

Actual results:
The encryption layer from /tmp/a to /tmp/b is created, but root or other users have no access to it.

Expected results:
Everyone on the system should have access to /tmp/b if the allow_other option is used.

Comment 1 Jan Engelhardt 2011-01-23 00:15:47 UTC
Fixed upstream in 2.8.

Comment 2 Robert Story 2011-07-07 21:41:47 UTC
There's a patch in Ubuntu's bug tracker, comment number 4: https://bugs.launchpad.net/ubuntu/+source/libpam-mount/+bug/670865

I downloaded the F14 src rpm, added this patch, rebuilt, installed, and it's working great.

Comment 3 Jan Engelhardt 2011-07-08 16:36:36 UTC
This is fixed since pam_mount 2.8 anyway.

Comment 4 Robert Story 2011-07-08 17:14:13 UTC
That'd be fantastic if 2.8 was in F14. Unfortunately, F14 and F15 still have 2.5.

Comment 5 Fedora Update System 2012-06-20 19:41:38 UTC
libHX-3.12.1-1.fc17,hxtools-20120514-1.fc17,pam_mount-2.13-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libHX-3.12.1-1.fc17,hxtools-20120514-1.fc17,pam_mount-2.13-1.fc17

Comment 6 Fedora Update System 2012-06-22 08:30:42 UTC
Package libHX-3.12.1-1.fc17, hxtools-20120514-1.fc17, pam_mount-2.13-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libHX-3.12.1-1.fc17 hxtools-20120514-1.fc17 pam_mount-2.13-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9767/libHX-3.12.1-1.fc17,hxtools-20120514-1.fc17,pam_mount-2.13-1.fc17
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-07-10 21:00:53 UTC
libHX-3.12.1-1.fc17, hxtools-20120514-1.fc17, pam_mount-2.13-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.