Bug 658526

Summary: 1.5E-18.fc14 breaks xdvi
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: Xaw3dAssignee: Stepan Kasal <kasal>
Status: CLOSED ERRATA QA Contact: Hans de Goede <hdegoede>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: ejsheldrake, hdegoede, kasal, pertusus
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Xaw3d-1.5E-19.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-01 22:01:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Orion Poplawski 2010-11-30 16:21:19 UTC
Description of problem:

With 1.5E-18.fc14 installed:

xdvi latex/2010/propnasa10.dvi
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Error: Aborting: no fontset found

I tried building xdvi with the newer Xaw3d but that didn't help.

Comment 1 Hans de Goede 2010-11-30 19:58:58 UTC
And this goes away if you downgrade to an older Xaw3d ?

Comment 2 Orion Poplawski 2010-11-30 20:33:05 UTC
Yes.

Comment 3 Hans de Goede 2010-11-30 22:12:04 UTC
Ok, this is very likely caused by this patch:
http://pkgs.fedoraproject.org/gitweb/?p=Xaw3d.git;a=blob;f=Xaw3d-1.5E-fontset.patch;h=fd20ba481b2d2a9cf39338eddfcdc488dba5d045;hb=HEAD

Which adds a bunch of error checking for missing fontsets. The real problem however is not the Xaw3d check, but the fact that xdvi is not finding some fonts. This could be a missing font dependency, or a wrong font set definition in xdvi.

I can comment out the patch in question in the Xaw3d package and do a new build if you want, but that is just hiding the problem.

Comment 4 Orion Poplawski 2010-11-30 22:18:40 UTC
At the moment, I just would like a working xdvi again :).  All I know at the moment is that it works fine with the old Xaw3d but not with the new one.  If we can fix it in xdvi I'm fine with that.

Comment 5 Hans de Goede 2010-12-01 14:10:20 UTC
Hi,

I've spend some time tracking this down, and this indeed is caused by the patch I linked from comment #3.

I've rewritten (removed large parts which were causing the problem) that patch, here is the new patch header which explains what was going on:

###
This is commit 762bcb8c50fd0256a545ad6ed2304403daca8081 from
Markus Steinborn <gnugv_maintainer@yahoo.de> Xaw3d git repo, with
the making a missing fontset abort changes removed, while keeping the
checks for missing fonts as those can lead to NULL ptr dereferences.

The checks for missing font sets is removed, because when the locale
is set to a UTF-8 locale (default now a days on most Linux distributions),
libXt will usually print:

Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset   

When resolving any fontset string, and return a NULL fontset.
For more details on this issue see:
http://tracker.xemacs.org/XEmacs/its/issue650

This however is not a fatal error (it means the default font set will be
used, and that some characters of the entire unicode range may not render
properly).

The changes in the original commit made this a fatal error causing many
programs, which worked fine before, to abort.
###

Expect an update for F-14 fixing this soon. Note I'll put the stable karma points needed at 1. So if you can give that update positive karma after testing it will go to stable immediately keeping the window in which there is (was) a regression small.

Thanks,

Hans

Comment 6 Fedora Update System 2010-12-01 14:20:06 UTC
Xaw3d-1.5E-19.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Xaw3d-1.5E-19.fc14

Comment 7 Edward Sheldrake 2010-12-01 14:37:14 UTC
The "Missing charsets in String to FontSet" messages are due to the lack of an encodings.dir file due to a packaging bug in xorg-x11-fonts-misc - bug #634039

Comment 8 Fedora Update System 2010-12-01 22:01:34 UTC
Xaw3d-1.5E-19.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.