Bug 6586

Summary: Red Hat linux 6.1 is having problems with AT&T Worldnet
Product: [Retired] Red Hat Linux Reporter: jsberrios
Component: pppAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: jsberrios
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-01 21:10:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jsberrios 1999-11-01 01:51:50 UTC
Red Hat Linux 6.1 is having problems getting connected with
AT&T Worldnet.  While using the instructions on the
following web pages to set up a ppp script
(http://www.wurd.com/wurd/software/dialers/linux.html) and
I have been unsuccessful to connec to AT&T.  The message I
get when I do a tail to /var/log/messages is:

Oct 27 15:58:29 gator chat[741]: CONNECT
Oct 27 15:58:29 gator chat[741]:  -- got it
Oct 27 15:58:29 gator chat[741]: send (^M)
Oct 27 15:58:29 gator pppd[740]: Serial connection
Oct 27 15:58:29 gator pppd[740]: Using interface ppp0
Oct 27 15:58:29 gator pppd[740]: Connect: ppp0 <-->
Oct 27 15:58:48 gator pppd[740]: Remote message:
Authentication Failed(PAP)
Oct 27 15:58:48 gator pppd[740]: CHAP authentication failed
Oct 27 15:58:54 gator pppd[740]: Connection terminated.
Oct 27 15:58:55 gator pppd[740]: Exit.

I took a spare hard disk and installed a clean copy of Red
Hat Linux 6.0 and was able to connect to AT&T using the same
scripts and kppp configuration I tried to use in Red Hat
Linux 6.1

I tried to use the ppp script, KPPP and RP3 on Red Hat Linux

Your help on this matter is greatly appreciated.


Comment 1 Michael K. Johnson 1999-11-08 19:19:59 UTC
The "noauth" flag might help here.  You can test it with the
following command:
echo "PPPOPTIONS=noauth" >> /etc/sysconfig/network-scripts/ifcfg-ppp0

We're about to release a new version of initscripts that adds the
"noauth" flag automatically and so will probably help in this case,
at least with rp3.

Comment 2 Michael K. Johnson 1999-11-17 15:25:59 UTC
I have been talking to the author of pppd about what the right
thing is to do in this case.  Our next release of initscripts
will probably avoid this problem altogether by removing the
default route automatically if the default route option is

Comment 3 Michael K. Johnson 1999-12-01 21:10:59 UTC
Oops, forgot to close this earlier, sorry.

Fixed in our current initscripts errata update.