Bug 659405

Summary: SELinux is preventing /usr/libexec/dovecot/imap from 'search' accesses on the directory /home/nim/.local.
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:bbbe85601511def042750c62b491d09264047e04f555bd25de1397e55a69e3a0
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-03 09:39:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nicolas Mailhot 2010-12-02 18:23:16 UTC
SELinux is preventing /usr/libexec/dovecot/imap from 'search' accesses on the directory /home/nim/.local.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that imap should be allowed search access on the .local directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep /usr/libexec/dovecot/imap /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:dovecot_t:s0
Target Context                unconfined_u:object_r:gconf_home_t:s0
Target Objects                /home/nim/.local [ dir ]
Source                        imap
Source Path                   /usr/libexec/dovecot/imap
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           dovecot-2.0.7-2.fc15
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.10-5.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 2.6.36.1-10.fc15.x86_64 #1 SMP Mon
                              Nov 29 14:41:22 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    jeu. 02 déc. 2010 19:22:38 CET
Last Seen                     jeu. 02 déc. 2010 19:22:38 CET
Local ID                      348e11d9-320f-4bab-b47f-ba0b44f84bbc

Raw Audit Messages
type=AVC msg=audit(1291314158.107:16255): avc:  denied  { search } for  pid=1395 comm="imap" name=".local" dev=dm-0 ino=70875 scontext=system_u:system_r:dovecot_t:s0 tcontext=unconfined_u:object_r:gconf_home_t:s0 tclass=dir

imap,dovecot_t,gconf_home_t,dir,search
type=SYSCALL msg=audit(1291314158.107:16255): arch=x86_64 syscall=stat success=yes exit=0 a0=14301a8 a1=7fff74a260c0 a2=7fff74a260c0 a3=1 items=0 ppid=10390 pid=1395 auid=4294967295 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=4294967295 comm=imap exe=/usr/libexec/dovecot/imap subj=system_u:system_r:dovecot_t:s0 key=(null)
imap,dovecot_t,gconf_home_t,dir,search

#============= dovecot_t ==============
allow dovecot_t gconf_home_t:dir search;

Comment 1 Daniel Walsh 2010-12-02 18:35:43 UTC
Are you storing mail under /home/nim/.local?

Comment 2 Nicolas Mailhot 2010-12-02 20:58:24 UTC
I moved my user mail store to .local/share/maildir/ since .local/share/ seems the correct root nowadays (thanks to xfg for trying to clean up the historical dotfile/dir mess)

Comment 3 Miroslav Grepl 2010-12-03 09:39:54 UTC
I have fixed "gnome_manage_data()" interface which will fix this issue.

Fixed in selinux-policy-3.9.10-6.fc15