Bug 659450

Summary: tuned should not own /etc/tmpfiles.d directory, systemd-units owns that directory.
Product: [Fedora] Fedora Reporter: Daniel Walsh <dwalsh>
Component: tunedAssignee: Jan Vcelak <jvcelak>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: jvcelak, notting, pknirsch, plautrba, tsmetana, twoerner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-03 10:14:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Daniel Walsh 2010-12-02 20:07:43 UTC
rpm -qf /etc/tmpfiles.d
systemd-units-15-1.fc15.x86_64
tuned-0.2.18-1.fc15.noarch

Comment 1 Petr Lautrbach 2010-12-03 09:09:45 UTC
I think that it is better to own this directory then to require systemd-units. It allows to use tuned without systemd (current upstart in rawhide use these files too). Same principle is used in bash-completion files:

$ rpm -qf /etc/bash_completion.d/
yum-3.2.28-5.fc14.noarch
yum-utils-1.1.28-1.fc14.noarch
git-1.7.3.2-1.fc14.x86_64
bash-completion-1.2-5.fc14.noarch
...

Comment 2 Jan Vcelak 2010-12-03 10:14:29 UTC
As Petr described, this is intended. I'm closing this bug report.

Comment 3 Daniel Walsh 2010-12-06 16:54:31 UTC
Bill do you agree with this?

Comment 4 Bill Nottingham 2010-12-06 17:01:05 UTC
Yes (as long as everything owns it with the same permissions.)