Bug 659622

Summary: Providing native systemd file for upcoming F15 Feature Systemd
Product: [Fedora] Fedora Reporter: Michał Piotrowski <mkkp4x4>
Component: irqbalanceAssignee: Anton Arapov <anton>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anton, johannbg, lpoetter, nhorman, nobody
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: irqbalance-0.56-3.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-15 17:29:42 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
irqbalance.service
none
src.rpm
none
x86_64.rpm none

Description Michał Piotrowski 2010-12-03 03:49:39 EST
Created attachment 464526 [details]
irqbalance.service

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability
Comment 1 Fedora Admin XMLRPC Client 2011-03-07 07:29:17 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Anton Arapov 2011-03-25 04:50:32 EDT
changes has been integrated.
Comment 3 Anton Arapov 2011-03-25 05:05:31 EDT
Fedora release 16 (Rawhide)
Linux dell-pe1950-05.lab.bos.redhat.com 2.6.39-0.rc0.git11.0.fc16.x86_64 #1 SMP Tue Mar 22 21:58:54 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

[root@dell-pe1950-05 ~]# service irqbalance status
irqbalance.service - LSB: start and stop irqbalance daemon
          Loaded: loaded (/etc/rc.d/init.d/irqbalance)
          Active: active (running)

[root@dell-pe1950-05 ~]# yum localinstall /root/rpmbuild/RPMS/x86_64/irqbalance-0.56-3.fc16.x86_64.rpm --nogpgcheck

[root@dell-pe1950-05 ~]# service irqbalance status
Redirecting to /bin/systemctl  status irqbalance.service
irqbalance.service - LSB: start and stop irqbalance daemon
          Loaded: loaded (/etc/rc.d/init.d/irqbalance)
          Active: active (running)

// system restart

[root@dell-pe1950-05 ~]# systemctl status irqbalance.service
irqbalance.service - irqbalance daemon
          Loaded: loaded (/lib/systemd/system/irqbalance.service)
          Active: active

// init.d scripts were cleaned-up successfully.

cat /proc/interrupts shows irqbalance works as expected.
Comment 4 Anton Arapov 2011-03-25 05:12:14 EDT
Created attachment 487507 [details]
src.rpm
Comment 5 Anton Arapov 2011-03-25 05:13:19 EDT
Created attachment 487508 [details]
x86_64.rpm
Comment 6 Anton Arapov 2011-03-25 05:14:51 EDT
koji is unable to build the src.rpm due to unawareness of the %{_unitdir}.
Comment 7 Fedora Update System 2011-04-08 07:41:17 EDT
irqbalance-0.56-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/irqbalance-0.56-3.fc15
Comment 8 Fedora Update System 2011-04-09 01:26:33 EDT
Package irqbalance-0.56-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing irqbalance-0.56-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/irqbalance-0.56-3.fc15
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-04-15 17:29:38 EDT
irqbalance-0.56-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.