Bug 660797

Summary: FTBFS sim-0.9.5-0.23.20091129svn3078rev.fc13
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: simAssignee: Pavel Alexeev <pahan>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: pahan, rc040203
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-13 05:49:35 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 659965    
Description Flags
mock.log none

Description FTBFS 2010-12-07 12:59:35 EST
sim-0.9.5-0.23.20091129svn3078rev.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 12:59:38 EST
Created attachment 465617 [details]

root.log for i386
Comment 2 FTBFS 2010-12-07 12:59:40 EST
Created attachment 465618 [details]

build.log for i386
Comment 3 FTBFS 2010-12-07 12:59:41 EST
Created attachment 465619 [details]

mock.log for i386
Comment 4 FTBFS 2010-12-07 12:59:43 EST
Created attachment 465620 [details]

root.log for x86_64
Comment 5 FTBFS 2010-12-07 12:59:45 EST
Created attachment 465621 [details]

build.log for x86_64
Comment 6 FTBFS 2010-12-07 12:59:46 EST
Created attachment 465622 [details]

mock.log for x86_64
Comment 7 Ralf Corsepius 2010-12-10 09:35:35 EST
Cause of this FTBFS is a missing BR: flex-static

I am not going to add it, but am leaving fixing this issue to this package's maintainer, because I feel this package hasn't had enough attention and needs a major overhaul.
Comment 8 Pavel Alexeev 2010-12-11 03:55:27 EST
Thank you, I'll look on it in few days.
Comment 9 Pavel Alexeev 2010-12-13 05:49:35 EST
I do not understand why it needed now, but conditional BR added.
Build should happened soon.
Comment 10 Ralf Corsepius 2010-12-13 06:50:07 EST
(In reply to comment #9)
> I do not understand why it needed now, but conditional BR added.
> Build should happened soon.

It actually is quite simple.

Without special preparations, flex or lex generated scanners typically use yywrap, which historically is supplied by libfl.* or libl.*

As libfl is really trival and small, it's developers consider only provide a static libfl.a (I agree with their reasoning).

In wery old Fedoras and RHs, libfl.a used to be part of the flex package, in more recent Fedoras, libfl.a is provided by the flex-static package.

Up to Fedora 14 the flex package had contained "Requires: flex-static", i.e. libfl.a was implicitly pulled in when using "Requires: flex".

In Fedora-15, the flex package doesn't "Requires: flex-static" anymore.

=> Packages using libfl now have to explicitly "BR: flex-static". This had caused a couple of FTBFS breakdowns.
Comment 11 Pavel Alexeev 2010-12-13 06:59:58 EST
Thank you for the explanation.