This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 660950

Summary: FTBFS WindowMaker-0.92.0-20.fc12: ImplicitDSOLinking
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: WindowMakerAssignee: Andreas Bierfert <andreas.bierfert>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: andreas.bierfert
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-08 16:59:44 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 659965    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2010-12-07 13:27:45 EST
WindowMaker-0.92.0-20.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-12-07 13:27:49 EST
Created attachment 466469 [details]
root.log


root.log for i386
Comment 2 FTBFS 2010-12-07 13:27:50 EST
Created attachment 466470 [details]
build.log


build.log for i386
Comment 3 FTBFS 2010-12-07 13:27:52 EST
Created attachment 466471 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2010-12-07 13:27:53 EST
Created attachment 466472 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2010-12-07 13:27:54 EST
Created attachment 466473 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2010-12-07 13:27:56 EST
Created attachment 466474 [details]
mock.log


mock.log for x86_64