Bug 661103

Summary: man subscription-manager needs changes due to fix for bug645115
Product: Red Hat Enterprise Linux 6 Reporter: John Sefler <jsefler>
Component: DocumentationAssignee: Devan Goodwin <dgoodwin>
Status: CLOSED CURRENTRELEASE QA Contact: John Sefler <jsefler>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1CC: bkearney, dlackey
Target Milestone: rcKeywords: Documentation, QA-Closed
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-23 21:51:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 639436    

Description John Sefler 2010-12-07 19:26:50 UTC
Description of problem:
After fixes have been put in place for https://bugzilla.redhat.com/show_bug.cgi?id=645115
The current man page for subscription manager needs to drop all occurrences of "/product" from the string "/etc/pki/entitlement/product"


Version-Release number of selected component (if applicable):
subscription-manager man page version...
version 1.0                    November 12, 2010       subscription-manager(8)


Addition Info:
How come Pradeep Kilambi is the only author?
DEON LACKEY should be the primary author!

Comment 2 Deon Ballard 2010-12-11 00:40:20 UTC
I changed the directory path. And I added my name as an author. :)

Link to the "view" in my svn repo:
http://svn.devel.redhat.com/cgi-bin/viewvc.cgi/ecs/dlackey/rhel61-drafts/manpage/subscription-manager.8?revision=53946&view=markup

Comment 3 Deon Ballard 2010-12-11 00:41:49 UTC
Oh, I also checked the chapter in the deployment guide, but it looks like I already corrected it there.

Comment 5 John Sefler 2010-12-21 20:20:07 UTC
Yes - it does look like all occurrences of "/product" from the string "/etc/pki/entitlement/product" have been dropped in Deon's view in her SVN repo.  The changes have not yet been folded into the subscription-manager.rpm.

Leaving this bug in MODIFIED state until Deon's latest has been integrated.

Comment 6 Deon Ballard 2010-12-21 20:28:21 UTC
I'm reassigning this to Devan, because I think he does the RHSM builds.

Comment 7 Devan Goodwin 2010-12-22 20:10:01 UTC
Applied latest manpage from URL above in: 3a50d662d0b089d9c69621a16c0f24160324c446

Comment 8 John Sefler 2011-01-06 16:02:13 UTC
[root@jsefler-onprem01 ~]# rpm -q subscription-manager
subscription-manager-0.93.9-1.git.15.3545a2a.el6.x86_64

[root@jsefler-onprem01 ~]# man subscription-manager | grep version
              distribution.version: 6.0
       ating  system  versions, and memory, are collected by Subscription Man-
version 1.0                    December 10, 2010       subscription-manager(8)

[root@jsefler-onprem01 ~]# man subscription-manager | grep pki
       openssl x509 -text -in /etc/pki/consumer/cert.pem
              * /etc/pki/consumer/*.pem
              * /etc/pki/entitlement/<serial>.pem
              * /etc/pki/product/*.pem
       Deon  Lackey, <dlackey@redhat.com>, and Pradeep Kilambi, <pkilambi@red-


moving to VERIFIED