Bug 661233

Summary: Duplicity needs upgrade to work with Amazon S3
Product: [Fedora] Fedora EPEL Reporter: David Anderson <fedora-packaging2>
Component: duplicityAssignee: Robert Scheck <redhat-bugzilla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: el5CC: redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: duplicity-0.6.11-1.el4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-25 00:28:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Anderson 2010-12-08 09:22:28 UTC
Hi,

Duplicity in 0.6.09 and 0.6.10 does not have working Amazon S3 (in the present EPEL 5, 0.6.09, the backend is not even present). This is a regression - it was working in 0.6.06.

0.6.11 has been released (2010/11/20), and the changelog states that they have now fixed this. Please can we have 0.6.11 in EPEL 5? Thank you!

Comment 1 Fedora Update System 2010-12-08 23:31:43 UTC
duplicity-0.6.11-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.fc14

Comment 2 Fedora Update System 2010-12-08 23:31:49 UTC
duplicity-0.6.11-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.fc13

Comment 3 Fedora Update System 2010-12-08 23:32:14 UTC
duplicity-0.6.11-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.el5

Comment 4 Fedora Update System 2010-12-08 23:32:23 UTC
duplicity-0.6.11-1.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.el4

Comment 5 David Anderson 2010-12-09 07:16:21 UTC
Hi,

Thanks for this.

On EPEL 5, I got no joy. The error message was always:

BackendException: Boto requires a bucket name
This is coming from line 155 of /usr/lib/python2.4/site-packages/duplicity/backends/botobackend.py

This was both without the duplicity --s3-use-new-style option, which is not supported by python-boto-1.0a (which the duplicity S3 (boto) backend uses) which is in EPEL 5.
(Note that this also means that users cannot use Amazon S3's European buckets, as for these --s3-use-new-style is mandatory: though mine is actually a US bucket so it should work without).

I then obtained python-boto-1.9 from rpmforge, and tried with that, and it worked.

So I think the python-boto package needs an update too in EPEL 5, otherwise S3 is still not working. I don't know enough to advise which version to use, all I can say is that 1.9 from rpmforge works.

Comment 6 Robert Scheck 2010-12-09 08:02:39 UTC
I'm going to prepare a python-boto update for EL-5, soon. If I let you know,
will you be able to test this python-boto update a lot?

Comment 7 David Anderson 2010-12-09 08:15:28 UTC
I'm not a python programmer, and the only part of python-boto I'm using is the S3 component - it seems to have many others. So all I can promise is that I'll test out duplicity via S3 thoroughly, but with other stuff I don't have the abilities I'm afraid - might be best to recruit testers from fedora-devel or something like that.

(Correction to earlier - the one from rpmforge is 1.9b, not 1.9)

Comment 8 Fedora Update System 2010-12-09 17:04:17 UTC
duplicity-0.6.11-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update duplicity'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/duplicity-0.6.11-1.el4

Comment 9 Fedora Update System 2010-12-25 00:28:22 UTC
duplicity-0.6.11-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-12-25 00:29:50 UTC
duplicity-0.6.11-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 David Anderson 2010-12-27 08:11:02 UTC
I've been using the version from epel-testing with python-boto from rpmforge with no problems for 3 weeks now.

Comment 12 Fedora Update System 2011-01-02 23:24:43 UTC
python-boto-1.9b-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-boto-1.9b-6.el5

Comment 13 Robert Scheck 2011-01-02 23:28:12 UTC
The update, I've submitted should be better than what RPMforge delivers,
because they never checked at all whether it is Python 2.4 compatible. I
at least fixed some issues to avoid Python syntax errors.

Please test this package and if it works, add positive karma to both, the
duplicity one and the python-boto one. Thank you.

Comment 14 Fedora Update System 2011-02-28 23:59:53 UTC
python-boto-1.9b-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-03-01 00:00:57 UTC
duplicity-0.6.11-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-03-01 00:02:35 UTC
duplicity-0.6.11-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.