Bug 661385

Summary: distorted sound on Flash websites (when playing in full screen)
Product: [Fedora] Fedora Reporter: Pablo Rodríguez <fedora>
Component: glibcAssignee: Andreas Schwab <schwab>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: jakub, schwab, spoyarek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-26 10:11:53 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Pablo Rodríguez 2010-12-08 12:25:05 EST
I have been using Fedora 13 for months with no issues on this topic, but since Fedora 14 I experience a weird bug consisting in that sound is played distorted on Flash (latest stable 10.1.102.65 version and even 10.2 beta) when full screen is active.

There is a similar report on bug 638477, but I'm on 32bits and the sound distortion only happens in Flash full screen mode.

I have commented the bug in https://bugzilla.redhat.com/show_bug.cgi?id=638477#c142, but I got no reply.

I wanted to check whether their fix at https://bugzilla.redhat.com/show_bug.cgi?id=638477#c55 will fix the issue I'm experiencing.

I'm afraid that my system is not able to compile:

#include <sys/types.h>

void *memcpy(void *dst, const void *src, size_t size)
{
void *orig = dst;
asm volatile("rep ; movsq"
:"=D" (dst), "=S" (src)
:"0" (dst), "1" (src), "c" (size >> 3)
:"memory");
asm volatile("rep ; movsb"
:"=D" (dst), "=S" (src)
:"0" (dst), "1" (src), "c" (size & 7)
:"memory");
return orig;
}

I get the following error:

$ gcc -O2 -c linusmemcpy.c
linusmemcpy.c: Assembler messages:
linusmemcpy.c:6: Error: number of operands mismatch for `movs'

It might be the most basic issue, but I cannot code, so it's Greek to me.

What am I missing here?

Thanks for your help,


Pablo
Comment 1 Siddhesh Poyarekar 2011-01-26 10:11:53 EST
I have added a comment in bug 638477 with a slightly modified program for this. I am not on cc list there, so I won't respond on the bug report in case you have any problems building it (it should though). Bugzilla is not a support tool anyway, so the right place to go would be the Fedora users list.

*** This bug has been marked as a duplicate of bug 638477 ***
Comment 2 Pablo Rodríguez 2011-01-26 11:18:54 EST
I don't think this is a duplicate of bug 638477 (https://bugzilla.redhat.com/show_bug.cgi?id=638477#c176).

I have tried to
Comment 3 Pablo Rodríguez 2011-01-26 11:22:41 EST
[Sorry, last comment was incomplete when I hit the “Save changes” button.]

The sound is distorted, not broken.

I haven't checked your patch for 32bits, since I read it doesn't work (https://bugzilla.redhat.com/show_bug.cgi?id=638477#c184).

Thanks for your help.