Bug 661455

Summary: SELinux is preventing /usr/bin/ettercap-tui "net_admin" access .
Product: [Fedora] Fedora Reporter: maurizio <antillon.maurizio>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:efbe0fab0b16b1ad8a2041490b0d8db93369e9f86f6ada3d160001b731d0e12a
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-08 20:36:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description maurizio 2010-12-08 19:32:19 UTC
Summary:

SELinux is preventing /usr/bin/ettercap-tui "net_admin" access .

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ettercap. It is not expected that this access
is required by ettercap and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                mauricio:user_r:user_t:s0-s0:c0.c1023
Target Context                mauricio:user_r:user_t:s0-s0:c0.c1023
Target Objects                None [ capability ]
Source                        ettercap
Source Path                   /usr/bin/ettercap-tui
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ettercap-0.7.3-36.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-69.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34.7-61.fc13.i686
                              #1 SMP Tue Oct 19 04:42:47 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Wed 08 Dec 2010 09:49:35 AM MST
Last Seen                     Wed 08 Dec 2010 09:49:35 AM MST
Local ID                      85aa45c4-9108-4ab5-bae3-fe5b87c9e4b5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1291826975.174:114): avc:  denied  { net_admin } for  pid=2631 comm="ettercap" capability=12  scontext=mauricio:user_r:user_t:s0-s0:c0.c1023 tcontext=mauricio:user_r:user_t:s0-s0:c0.c1023 tclass=capability

node=(removed) type=SYSCALL msg=audit(1291826975.174:114): arch=40000003 syscall=5 success=yes exit=6 a0=809ac5e a1=0 a2=1b6 a3=80992a1 items=0 ppid=2620 pid=2631 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm="ettercap" exe="/usr/bin/ettercap-tui" subj=mauricio:user_r:user_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,ettercap,user_t,user_t,capability,net_admin
audit2allow suggests:

#============= user_t ==============
allow user_t self:capability net_admin;

Comment 1 Daniel Walsh 2010-12-08 20:36:01 UTC

*** This bug has been marked as a duplicate of bug 661409 ***