Bug 662163

Summary: Image too white
Product: [Fedora] Fedora Reporter: Bob Goodwin <bobgoodwin>
Component: kernelAssignee: Hans de Goede <hdegoede>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 14CC: dougsland, gansalmon, hdegoede, itamar, jonathan, kernel-maint, madhu.chinakonda, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-15 15:45:44 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bob Goodwin 2010-12-10 14:06:55 EST
Description of problem: The displayed image is too white in normal daytime room light. There is a usable image at night with reduced illumination. 


Version-Release number of selected component (if applicable):Camorama 0.19


How reproducible:Very, always manifest.


Steps to Reproduce:
1.Start camorama webcam viewer
2.Look at image produced.
3.
  
Actual results:Reprouces only darkest parts of image, remainder goes to white. The problem can not be corrected with brightness, contrast, or whitemess controls. All are already at minimum upon starting. Operation is normal with WindowsXP on this same computer.


Expected results:Recognizable image.


Additional info:Bus 003 Device 002: ID 046d:0870 Logitech, Inc. QuickCam Express 

*-usb
                           description: Generic USB device
                           product: Camera
                           vendor: Logitech, Inc.
                           physical id: 2
                           bus info: usb@3:2
                           version: 1.00
                           capabilities: usb-1.10
                           configuration: driver=STV06xx maxpower=90mA
       speed=12Mbit/s
Comment 1 Hans de Goede 2010-12-15 10:53:19 EST
Hi,

This is not a cheese problem, but rather a problem with the driver for your webcam likely the autoexposure algorithm is not doing the right thing in your specific circumstances.

Since getting autoexposure right in all circumstances is rather tricky, the
best solution is probably to just turn it of.

Do as root:
yum install gtk-v4l

And then start gtk-v4l, Expand the more properties expander, unselect auto matic exposure, and then manually adjust the exposure and gain to your liking.

Please let me know if this fixes things.

Thanks & Regards,

Hans
Comment 2 Hans de Goede 2010-12-15 15:45:44 EST
This has been further discussed by mail, and manually controlling the exposure seems to fix this, closing.