This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 66330

Summary: twm IconManagerFont configuration directive has no effect
Product: [Retired] Red Hat Linux Reporter: Bryan Ischo <bji-rhb>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: nbi
Target Milestone: ---Keywords: MoveUpstream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-04-19 22:59:58 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bryan Ischo 2002-06-07 18:58:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3smp i686)

Description of problem:
As of RedHat 7.3, the twm window manager cannot be made to use any
font in the icon manager other than a bold fixed-width font.  The
old "variable" font, which is the default, does not show up.  Using
the IconManagerFont configuration directive in one's $HOME/.twmrc file
has no effect.  Weird.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a $HOME/.twmrc file with the IconManagerFont directive set
to anything you like, e.g. IconManagerFont "5x8"
2. Run twm as your window manager.
3. Note that the font in the icon manager is still fixed bold.  Choose another
font for your IconManagerFont, and the fixed bold font will still be used.

	

Actual Results:  Got a fixed bold font in the icon manager.

Expected Results:  Expected to get whatever font is specified via the
IconManagerFont directive, or the standard "variable" font if none is specified.


Additional info:
Comment 1 Mike A. Harris 2002-06-10 00:30:37 EDT
I'll have a look.  Can you please also report this problem to
xpert@xfree86.org mailing list so more people are aware of the problem.

Thanks.
Comment 2 Bryan Ischo 2002-06-10 14:13:25 EDT
I have sent a message regarding this bug to xpert@xfree86.org as requested.
Comment 3 Mike A. Harris 2002-11-07 06:52:56 EST
Defering waiting for future upstream XFree86 release.
Comment 4 Mike A. Harris 2002-11-20 11:12:56 EST
*** Bug 78092 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2003-03-15 02:57:06 EST
Closing bug, assuming it is fixed in 4.3.0 in RAWHIDE.
Comment 6 Bryan Ischo 2003-06-12 23:28:34 EDT
I am re-opening this bug because the problem has NOT been fixed yet, as of 
RedHat 9.  I have tried the most recent XFree86-twm RPM (version 4.3.0-8), and 
the bug is not only there, but worse since 7.3.

Bug 78092 describes the current problem: now the icon manager and root menu 
fonts are completely messed up and no text shows up at all.  No TWM 
configuration directive fixes this problem.  This renders TWM unuseable.
Comment 7 Bryan Ischo 2003-06-13 12:30:40 EDT
By delving into the TWM source I have found a workaround: make sure that the
LC_ALL environment variable is set to C, as in:

LC_ALL=C twm &

The code for twm uses XFontSet stuff if and only iff the locale is not C and not
POSIX.  When using XFontSet stuff, it looks like TWM is thoroughly broken.  But
when using normal fonts, it works fine.

I would recommend removing the support for locales from TWM until TWM works with
them correctly.  The simplest way to do this would be to always set the
"use_fontset" variable in twm.c to false, rather than setting it to true if the
locale is not C and not POSIX.
Comment 8 Mike A. Harris 2004-04-19 22:59:58 EDT
There are not that many people who still use twm nowadays, and
there haven't been any other reports of this problem in our bugzilla,
so unfortunately, it probably will never make the priority bug list
in all reality.  Rather than just leave it sit here to never be
addressed however, I think if you report the issue upstream to
our current upstream X source (X.org X11), this issue stands a
better chance of being investigated and resolved in some manner in
a future OS release, and possibly the fixes can be easily backported
for erratum of older releases.

First, please confirm wether or not the issue exists in Fedora
Core 2 test2 release or later, and if so, please report the issue
upstream at: http://xorg.freedesktop.org against the 'xorg'
component.  Once you've filed the report upstream, paste the
upstream bug URL here, and reopen this report if you like, and
we will track the upstream issue periodically and review their
resolution when it becomes available.

Thanks in advance.

Closing as 'WONTFIX' for now.

I