Bug 664636

Summary: Banshee crashes under KDE. Works fine in Gnome.
Product: [Fedora] Fedora Reporter: Andy Wang <dopey>
Component: bansheeAssignee: Christian Krause <chkr>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 14CC: brendan.jones.it, chkr, nathaniel, tcallawa
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: banshee-1.8.0-10.fc14.1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-12 05:23:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
banshee crash stack none

Description Andy Wang 2010-12-21 03:25:06 UTC
Created attachment 469892 [details]
banshee crash stack

Description of problem:
Banshee crashes under KDE. It starts and works fine under Gnome.

Version-Release number of selected component (if applicable):
banshee-1.8.0-10.fc14.x86_64

How reproducible:
Always reproducible.  Under KDE, banshee crashes with the attached stack trace.

Steps to Reproduce:
1. Login under KDE
2. Start banshee
  
Actual results:
Banshee crashes

Expected results:
Banshee runs

Comment 1 Brendan Jones 2010-12-21 12:55:01 UTC
Thanks for the report. 

I can reproduce this here with the same backtrace under KDE. Could not see any relevant bug reports upstream.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Christian Krause 2010-12-30 21:43:39 UTC
So far I could not reproduce the problem on a 32bit system.

Just to narrow down the issue, please can you try the following:
- start banshee in a GNOME session
- disable the "Notification Area Icon" extension:
Edit -> Preferences -> Extensions: Utilities / Notification Area Icon
and let me know whether it helped?

Comment 3 Andy Wang 2010-12-31 04:54:51 UTC
Yup, disabling the Notification Area Icon worked.

Comment 4 Christian Krause 2011-01-02 01:23:50 UTC
I have tracked down the issue and I have reported my findings upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=638477

I will provide a new package with this fix for F14 within the next days.

Comment 5 Fedora Update System 2011-01-02 20:42:46 UTC
banshee-1.8.0-10.fc14.1 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/banshee-1.8.0-10.fc14.1

Comment 6 Fedora Update System 2011-01-03 20:06:23 UTC
banshee-1.8.0-10.fc14.1 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update banshee'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/banshee-1.8.0-10.fc14.1

Comment 7 Andy Wang 2011-01-04 03:23:09 UTC
Thanks for fixing this so fast.  I just tried it and yup, it works now.

Comment 8 Fedora Update System 2011-01-12 05:23:05 UTC
banshee-1.8.0-10.fc14.1 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.