Bug 665128

Summary: Candlepin should just store the product name in the pool.
Product: [Community] Candlepin Reporter: Bryan Kearney <bkearney>
Component: candlepinAssignee: Devan Goodwin <dgoodwin>
Status: CLOSED CURRENTRELEASE QA Contact: John Sefler <jsefler>
Severity: medium Docs Contact:
Priority: low    
Version: 0.5CC: dgoodwin
Target Milestone: ---Keywords: QA-Closed
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-23 21:51:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 639436    

Description Bryan Kearney 2010-12-22 19:51:05 UTC
Candlepin today attempts to calculate the prodcut name on the fly. It should, instead, just store it in the DB all the time. To do this, the following changes should be made:

1) When creating the pool, set the product name to the result of calling getProductNamesByProductId
2) Ensure this is persistted.
3) remove the calls to addProductName in the curator.

Comment 1 Devan Goodwin 2011-01-14 15:56:41 UTC
Fixed in candlepin.git:

master: f4609c8c4480c1ed8326b89612ed05d7a08ceae8
BETA: f9385c6f56b860a84892726c06eb56d1c59d95da

Comment 2 John Sefler 2011-01-24 15:24:00 UTC
Devan,Bryan,
Can you verify this bugzilla since it appears to be a change in code implementation with results that are transparent to the end user.

Comment 3 Devan Goodwin 2011-01-26 19:06:32 UTC
We've killed off the code that set these on the fly, added code to set them when pools are created. This code has been deployed in IT for awhile, product names are appearing healthy, unit tests passing, going to call it verified.