Bug 665679

Summary: Boost library does not come with libboost_random, so random_device is unusable
Product: [Fedora] Fedora Reporter: Hedayat Vatankhah <hedayatv>
Component: boostAssignee: Petr Machata <pmachata>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: bkoz, denis.arnaud_fedora, mnewsome, pertusus, pmachata
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: boost-1.44.0-7.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-18 21:39:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Fix boost build none

Description Hedayat Vatankhah 2010-12-25 23:47:40 UTC
Description of problem:
Boost library provides a random_device class, which is not a header-only class. So, to use this class in a code, the code should be linked with the library containing the implementation of this class. But Fedora doesn't provide any appropriate libraries.

Version-Release number of selected component (if applicable):
1.44.0-4

How reproducible:
100%

Comment 1 Petr Machata 2011-01-03 16:16:42 UTC
Created attachment 471509 [details]
Fix boost build

CMakeLists of random library doesn't mention src/.  This patch adds the necessary scaffolding.  I have a build in progress and it seems to be doing the right thing (except that I need to adjust the spec file).  Note that this is not upstreamable, the patch patches generated files.  I'll need to look into that.

Comment 2 Fedora Update System 2011-01-03 18:40:57 UTC
boost-1.44.0-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/boost-1.44.0-5.fc14

Comment 3 Fedora Update System 2011-01-04 20:58:51 UTC
boost-1.44.0-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update boost'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/boost-1.44.0-5.fc14

Comment 4 Fedora Update System 2011-01-06 16:42:24 UTC
boost-1.44.0-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/boost-1.44.0-6.fc14

Comment 5 Fedora Update System 2011-01-10 23:11:59 UTC
boost-1.44.0-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/boost-1.44.0-7.fc14

Comment 6 Fedora Update System 2011-01-18 21:38:49 UTC
boost-1.44.0-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.