Bug 666441

Summary: OMAPI doesn't work, and causes DHCPD cpu usage to spike to 100%
Product: [Fedora] Fedora Reporter: Scott Baker <scott>
Component: dhcpAssignee: Jiri Popelka <jpopelka>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: jpopelka
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dhcp-4.2.0-18.P2.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-25 16:00:14 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Scott Baker 2010-12-30 14:28:17 EST
Description of problem: OMAPI in dhcpd is not working


Version-Release number of selected component (if applicable): dhcp-4.2.0-16.P2.fc14.x86_64

How reproducible: Easy

Steps to Reproduce:
1. Enable omapi in the config
2. Attempt to connect 
3. Get the "dhcpctl_connect: operation in progress" message
  
Actual results: DHCPD cpu usage spikes to 100%, and the "dhcpctl_connect: operation in progress" message displays

Expected results: OMAPI connects

Additional info: Looks like this is documented here: http://www.mentby.com/Group/dhcp-users/omapi-not-working-in-420.html. There is a fix mentioned but I'm unable to test it.

Not being able to us omapi really cripples our DHCP installation. We're unable to manually remove leases or do any sort of failover between two DHCP servers with OMAPI not functioning.
Comment 1 Jiri Popelka 2011-01-03 11:39:17 EST
Please try this build:
https://koji.fedoraproject.org/koji/buildinfo?buildID=212430
Comment 2 Scott Baker 2011-01-03 11:47:54 EST
[root@virt2 tmp]# yum install dhclient-4.2.0-17.P2.fc14.x86_64.rpm dhcp-4.2.0-17.P2.fc14.x86_64.rpm 
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: mirrors.versaweb.com
 * base: mirror.sanctuaryhost.com
 * extras: ftp.osuosl.org
 * updates: mirror.its.uidaho.edu
Setting up Install Process
Examining dhclient-4.2.0-17.P2.fc14.x86_64.rpm: 12:dhclient-4.2.0-17.P2.fc14.x86_64
Marking dhclient-4.2.0-17.P2.fc14.x86_64.rpm as an update to 12:dhclient-3.0.5-23.el5_5.2.x86_64
Examining dhcp-4.2.0-17.P2.fc14.x86_64.rpm: 12:dhcp-4.2.0-17.P2.fc14.x86_64
Marking dhcp-4.2.0-17.P2.fc14.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package dhclient.x86_64 12:4.2.0-17.P2.fc14 set to be updated
--> Processing Dependency: libc.so.6(GLIBC_2.8)(64bit) for package: dhclient
--> Processing Dependency: libcap-ng.so.0()(64bit) for package: dhclient
--> Processing Dependency: liblber-2.4.so.2()(64bit) for package: dhclient
--> Processing Dependency: libldap-2.4.so.2()(64bit) for package: dhclient
---> Package dhcp.x86_64 12:4.2.0-17.P2.fc14 set to be updated
--> Processing Dependency: liblber-2.4.so.2()(64bit) for package: dhcp
--> Processing Dependency: libldap-2.4.so.2()(64bit) for package: dhcp
--> Finished Dependency Resolution
12:dhclient-4.2.0-17.P2.fc14.x86_64 from /dhclient-4.2.0-17.P2.fc14.x86_64 has depsolving problems
  --> Missing Dependency: libldap-2.4.so.2()(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
12:dhcp-4.2.0-17.P2.fc14.x86_64 from /dhcp-4.2.0-17.P2.fc14.x86_64 has depsolving problems
  --> Missing Dependency: libldap-2.4.so.2()(64bit) is needed by package 12:dhcp-4.2.0-17.P2.fc14.x86_64 (/dhcp-4.2.0-17.P2.fc14.x86_64)
12:dhclient-4.2.0-17.P2.fc14.x86_64 from /dhclient-4.2.0-17.P2.fc14.x86_64 has depsolving problems
  --> Missing Dependency: libcap-ng.so.0()(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
12:dhclient-4.2.0-17.P2.fc14.x86_64 from /dhclient-4.2.0-17.P2.fc14.x86_64 has depsolving problems
  --> Missing Dependency: liblber-2.4.so.2()(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
12:dhclient-4.2.0-17.P2.fc14.x86_64 from /dhclient-4.2.0-17.P2.fc14.x86_64 has depsolving problems
  --> Missing Dependency: libc.so.6(GLIBC_2.8)(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
12:dhcp-4.2.0-17.P2.fc14.x86_64 from /dhcp-4.2.0-17.P2.fc14.x86_64 has depsolving problems
  --> Missing Dependency: liblber-2.4.so.2()(64bit) is needed by package 12:dhcp-4.2.0-17.P2.fc14.x86_64 (/dhcp-4.2.0-17.P2.fc14.x86_64)
Error: Missing Dependency: liblber-2.4.so.2()(64bit) is needed by package 12:dhcp-4.2.0-17.P2.fc14.x86_64 (/dhcp-4.2.0-17.P2.fc14.x86_64)
Error: Missing Dependency: libldap-2.4.so.2()(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
Error: Missing Dependency: libcap-ng.so.0()(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
Error: Missing Dependency: libc.so.6(GLIBC_2.8)(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
Error: Missing Dependency: liblber-2.4.so.2()(64bit) is needed by package 12:dhclient-4.2.0-17.P2.fc14.x86_64 (/dhclient-4.2.0-17.P2.fc14.x86_64)
Error: Missing Dependency: libldap-2.4.so.2()(64bit) is needed by package 12:dhcp-4.2.0-17.P2.fc14.x86_64 (/dhcp-4.2.0-17.P2.fc14.x86_64)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Where do I get those ldap libraries? Or why is it asking for them?
Comment 3 Jiri Popelka 2011-01-03 12:00:56 EST
These libraries are in openldap package.

Try to update dhcp with
yum --nogpgcheck localupdate dhcp-4.2.0-17.P2.fc14.x86_64.rpm

or install it (if there's no older dhcp package on your system)
yum --nogpgcheck localinstall dhcp-4.2.0-17.P2.fc14.x86_64.rpm
Comment 4 Jiri Popelka 2011-01-03 12:03:58 EST
(In reply to comment #2)
> [root@virt2 tmp]# yum install dhclient-4.2.0-17.P2.fc14.x86_64.rpm
> dhcp-4.2.0-17.P2.fc14.x86_64.rpm 
> < ... >
> Marking dhclient-4.2.0-17.P2.fc14.x86_64.rpm as an update to
> 12:dhclient-3.0.5-23.el5_5.2.x86_64
> < ... >

Wait a moment. You are trying to install it on RHEL-5 ? That won't gonna fly ?
Comment 5 Scott Baker 2011-01-03 12:14:01 EST
Ya sorry about that... my bad. I sshed in to the WRONG box. Testing again now on the right box :)
Comment 6 Scott Baker 2011-01-03 12:52:42 EST
Sorry about that initial confusion. I installed the version of DHCP you linked to on my server and I can now run omshell and clear leases. I'll let it run for a day or so to make sure, but so far it looks great.
Comment 7 Fedora Update System 2011-01-20 09:33:59 EST
dhcp-4.2.0-18.P2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/dhcp-4.2.0-18.P2.fc14
Comment 8 Fedora Update System 2011-01-20 14:56:10 EST
dhcp-4.2.0-18.P2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/dhcp-4.2.0-18.P2.fc14
Comment 9 Fedora Update System 2011-01-25 15:59:59 EST
dhcp-4.2.0-18.P2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.