Bug 666649

Summary: ondemand frequency scaling broken with Pentium4D CPU
Product: [Fedora] Fedora Reporter: Steven Haigh <netwiz>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: gansalmon, itamar, jfrieben, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-11 06:33:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
dmesg output of boot with cpufreq.debug=7 in kernel command line. none

Description Steven Haigh 2011-01-01 21:42:36 UTC
Created attachment 471350 [details]
dmesg output of boot with cpufreq.debug=7 in kernel command line.

Description of problem:
After installing cpuspeed and attempting to use ondemand frequency scaling, it seems that acpi-cpufreq does not work - falling back to p4clockmod. This CPU should be modern enough to support acpi frequency scaling.

The system in question is an Acer AcerPower SK50.

Version-Release number of selected component (if applicable):
kernel-2.6.35.10-74.fc14.i686
kernel-2.6.37-0.rc7.git0.2.fc15.i686

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora
2. Install cpuspeed package
3. Observe frequency scaling support.
  
Actual results:
Scaling only happens with DRIVER=p4-clockmod & GOVERNOR=userspace and the cpuspeed daemon running. 

Expected results:
ondemand scaling should work out of the box.

Additional info:
In following posts.

Comment 1 Steven Haigh 2011-01-01 21:44:50 UTC
# for x in /sys/devices/system/cpu/cpu0/cpufreq/*;do echo $x;cat $x;done && for x in /sys/devices/system/cpu/cpu0/cpufreq/ondemand/*;do echo $x;cat $x;done
/sys/devices/system/cpu/cpu0/cpufreq/affected_cpus
0
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq
2800000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq
2800000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq
350000
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_transition_latency
10000001
/sys/devices/system/cpu/cpu0/cpufreq/related_cpus
0
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
350000 700000 1050000 1400000 1750000 2100000 2450000 2800000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
userspace performance
/sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
2800000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
p4-clockmod
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
userspace
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
2800000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
350000
/sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
2800000
/sys/devices/system/cpu/cpu0/cpufreq/ondemand/*
cat: /sys/devices/system/cpu/cpu0/cpufreq/ondemand/*: No such file or directory

Comment 2 Steven Haigh 2011-01-01 21:48:39 UTC
# cpufreq-info
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: p4-clockmod
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.00 ms.
  hardware limits: 350 MHz - 2.80 GHz
  available frequency steps: 350 MHz, 700 MHz, 1.05 GHz, 1.40 GHz, 1.75 GHz, 2.10 GHz, 2.45 GHz, 2.80 GHz
  available cpufreq governors: userspace, performance
  current policy: frequency should be within 350 MHz and 2.80 GHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 2.80 GHz (asserted by call to hardware).
analyzing CPU 1:
  driver: p4-clockmod
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.00 ms.
  hardware limits: 350 MHz - 2.80 GHz
  available frequency steps: 350 MHz, 700 MHz, 1.05 GHz, 1.40 GHz, 1.75 GHz, 2.10 GHz, 2.45 GHz, 2.80 GHz
  available cpufreq governors: userspace, performance
  current policy: frequency should be within 350 MHz and 2.80 GHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 2.80 GHz (asserted by call to hardware).

Comment 3 Joachim Frieben 2011-01-02 09:05:49 UTC
*** Duplicate of bug 505837 ***